# Academy LMS <= 4.0.7 - Authenticated (Academy Instructor+) Missing Authorization to Plugin Settings Disclosure

- **ID:** WPSEC-2026-1671
- **Plugin:** Academy LMS – WordPress LMS Plugin for Complete eLearning Solution (`academy`), https://wordpress.org/plugins/academy/
- **Affected versions:** all versions before 4.0.8
- **Fixed in:** 4.0.8 (Update to 4.0.8 or later.)
- **Severity:** Medium 4.3 (CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N)
- **Weakness:** CWE-862
- **Usage among sites WPSec scans:** plugin Low, affected versions None seen (as of 2026-10-27)
- **Attack surface analysis:** https://attacksurface.wpsec.com/plugin/academy
- **Fix released:** 2026-10-25
- **Published:** 2026-10-26
- **URL:** https://wpsec.com/vuln/WPSEC-2026-1671/

## Description

The academy plugin for WordPress is vulnerable to Sensitive Information Exposure via the settings REST endpoint in all versions up to, and including, 4.0.7, due to a permission callback that grants access to any user with the 'manage_academy_instructor' capability instead of only site administrators. This makes it possible for authenticated attackers, with Academy Instructor-level access and above, to read the plugin's global settings, including the stored ChatGPT (OpenAI) API key.

## References

- https://wpsec.com/vuln/WPSEC-2026-1671/
- https://plugins.svn.wordpress.org/academy/tags/4.0.8/
- https://wordpress.org/plugins/academy/

Source: WPSec, https://wpsec.com/vuln/WPSEC-2026-1671/

License: CC BY 4.0 (https://creativecommons.org/licenses/by/4.0/). Free to use, share and adapt, also commercially, if you credit WPSec and link to this advisory.
