{
 "id": "WPSEC-2026-1673",
 "url": "https://wpsec.com/vuln/WPSEC-2026-1673/",
 "json_url": "https://wpsec.com/vuln/WPSEC-2026-1673/advisory.json",
 "markdown_url": "https://wpsec.com/vuln/WPSEC-2026-1673/index.md",
 "title": "Autoptimize <= 3.1.16 - Authenticated (Contributor+) Stored Cross-Site Scripting via Google Fonts Optimization",
 "description": "The Autoptimize plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the Google Fonts optimization feature in all versions up to, and including, 3.1.16 due to insufficient output escaping of the font-family string taken from Google Fonts URLs found in the page HTML. That string, which is URL-decoded for Google Fonts API v2 URLs, is placed without escaping into the href attribute of the combined Google Fonts <link> tag. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an affected page. Exploitation requires the Google Fonts option to be set to one of the non-default 'combine and link' or 'combine and preload' modes.",
 "plugin": {
  "slug": "autoptimize",
  "name": "Autoptimize",
  "full_name": "Autoptimize",
  "wordpress_org": "https://wordpress.org/plugins/autoptimize/",
  "advisories_url": "https://wpsec.com/vuln/plugin/autoptimize/",
  "attacksurface": "https://attacksurface.wpsec.com/plugin/autoptimize"
 },
 "type": "XSS",
 "cwe": [
  "CWE-79"
 ],
 "cve": [],
 "cvss": {
  "version": "3.1",
  "score": 4.9,
  "vector": "CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:L/I:L/A:N",
  "severity": "Medium"
 },
 "affected": {
  "ranges": [
   {
    "from": null,
    "from_inclusive": true,
    "to": "3.1.17",
    "to_inclusive": false
   }
  ],
  "text": [
   "all versions before 3.1.17"
  ]
 },
 "introduced_in": null,
 "fixed_in": "3.1.17",
 "remediation": "Update to 3.1.17 or later.",
 "fix_released": "2026-10-25T17:16:06+00:00",
 "published": "2026-10-26T17:42:37+00:00",
 "updated": "2026-10-26T09:44:56.053971+00:00",
 "also_published_as": null,
 "references": [
  "https://wpsec.com/vuln/WPSEC-2026-1673/",
  "https://plugins.svn.wordpress.org/autoptimize/tags/3.1.17/",
  "https://wordpress.org/plugins/autoptimize/"
 ],
 "attacksurface_url": "https://attacksurface.wpsec.com/plugin/autoptimize",
 "source": "WPSec",
 "license": {
  "name": "CC BY 4.0",
  "url": "https://creativecommons.org/licenses/by/4.0/"
 },
 "usage": {
  "plugin": "High",
  "affected_versions": "High",
  "as_of": "2026-10-27"
 }
}