{
 "id": "WPSEC-2026-1687",
 "url": "https://wpsec.com/vuln/WPSEC-2026-1687/",
 "json_url": "https://wpsec.com/vuln/WPSEC-2026-1687/advisory.json",
 "markdown_url": "https://wpsec.com/vuln/WPSEC-2026-1687/index.md",
 "title": "Advanced Post Block <= 2.5.1 - Authenticated (Contributor+) Stored Cross-Site Scripting via Custom SVG Icon Block Attributes",
 "description": "The Advanced Post Block plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the custom SVG icon block attributes (Read More icon and Accordion layout up/down indicator icons) in all versions up to, and including, 2.5.1, due to insufficient input sanitization and output escaping. The front-end script renders these attributes as raw HTML, and the block settings are embedded in the page in a way that lets saved HTML entities decode back into live markup. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.",
 "plugin": {
  "slug": "advanced-post-block",
  "name": "Advanced Post Block",
  "full_name": "Advanced Post Block – Display Your Posts Exactly How You Want",
  "wordpress_org": "https://wordpress.org/plugins/advanced-post-block/",
  "advisories_url": "https://wpsec.com/vuln/plugin/advanced-post-block/",
  "attacksurface": "https://attacksurface.wpsec.com/plugin/advanced-post-block"
 },
 "type": "XSS",
 "cwe": [
  "CWE-79"
 ],
 "cve": [],
 "cvss": {
  "version": "3.1",
  "score": 6.4,
  "vector": "CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N",
  "severity": "Medium"
 },
 "affected": {
  "ranges": [
   {
    "from": "2.2.0",
    "from_inclusive": true,
    "to": "2.5.2",
    "to_inclusive": false
   }
  ],
  "text": [
   "from 2.2.0 before 2.5.2"
  ]
 },
 "introduced_in": "2.2.0",
 "fixed_in": "2.5.2",
 "remediation": "Update to 2.5.2 or later.",
 "fix_released": "2026-10-26T04:00:01+00:00",
 "published": "2026-10-27T04:44:52+00:00",
 "updated": "2026-10-26T09:31:11.568774+00:00",
 "also_published_as": null,
 "references": [
  "https://wpsec.com/vuln/WPSEC-2026-1687/",
  "https://plugins.svn.wordpress.org/advanced-post-block/tags/2.5.2/",
  "https://wordpress.org/plugins/advanced-post-block/"
 ],
 "attacksurface_url": "https://attacksurface.wpsec.com/plugin/advanced-post-block",
 "source": "WPSec",
 "license": {
  "name": "CC BY 4.0",
  "url": "https://creativecommons.org/licenses/by/4.0/"
 },
 "usage": {
  "plugin": "Low",
  "affected_versions": "Low",
  "as_of": "2026-10-27"
 }
}