# Advanced Post Block <= 2.5.1 - Authenticated (Contributor+) Stored Cross-Site Scripting via Custom SVG Icon Block Attributes

- **ID:** WPSEC-2026-1687
- **Plugin:** Advanced Post Block – Display Your Posts Exactly How You Want (`advanced-post-block`), https://wordpress.org/plugins/advanced-post-block/
- **Affected versions:** from 2.2.0 before 2.5.2
- **Fixed in:** 2.5.2 (Update to 2.5.2 or later.)
- **Severity:** Medium 6.4 (CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N)
- **Weakness:** CWE-79
- **Usage among sites WPSec scans:** plugin Low, affected versions Low (as of 2026-10-27)
- **Attack surface analysis:** https://attacksurface.wpsec.com/plugin/advanced-post-block
- **Fix released:** 2026-10-26
- **Published:** 2026-10-27
- **URL:** https://wpsec.com/vuln/WPSEC-2026-1687/

## Description

The Advanced Post Block plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the custom SVG icon block attributes (Read More icon and Accordion layout up/down indicator icons) in all versions up to, and including, 2.5.1, due to insufficient input sanitization and output escaping. The front-end script renders these attributes as raw HTML, and the block settings are embedded in the page in a way that lets saved HTML entities decode back into live markup. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

## References

- https://wpsec.com/vuln/WPSEC-2026-1687/
- https://plugins.svn.wordpress.org/advanced-post-block/tags/2.5.2/
- https://wordpress.org/plugins/advanced-post-block/

Source: WPSec, https://wpsec.com/vuln/WPSEC-2026-1687/

License: CC BY 4.0 (https://creativecommons.org/licenses/by/4.0/). Free to use, share and adapt, also commercially, if you credit WPSec and link to this advisory.
