{
 "id": "WPSEC-2026-1690",
 "url": "https://wpsec.com/vuln/WPSEC-2026-1690/",
 "json_url": "https://wpsec.com/vuln/WPSEC-2026-1690/advisory.json",
 "markdown_url": "https://wpsec.com/vuln/WPSEC-2026-1690/index.md",
 "title": "Panorama – 360 degree Virtual Tour, Panoramic Image viewer and More <= 1.8.3 - Authenticated (Shop Manager+) Stored Cross-Site Scripting via Product Spot Hotspot Icons",
 "description": "The Panorama plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the WooCommerce product Product Spot settings (hotspot 'icon' and 'globalIcon' values) in all versions up to, and including, 1.8.3, due to insufficient input sanitization and output escaping. The plugin stores these values in product meta without sanitizing them, and the Product Spot block's front-end script inserts them into the page as raw HTML. This makes it possible for authenticated attackers, with Shop Manager-level access and above, to inject arbitrary web scripts in product pages that will execute whenever a user accesses an injected page.",
 "plugin": {
  "slug": "panorama",
  "name": "Panorama – 360 degree Virtual Tour, Panoramic Image viewer and More",
  "full_name": "Panorama – Turn Photos into Immersive Virtual Tours",
  "wordpress_org": "https://wordpress.org/plugins/panorama/",
  "advisories_url": "https://wpsec.com/vuln/plugin/panorama/",
  "attacksurface": "https://attacksurface.wpsec.com/plugin/panorama"
 },
 "type": "XSS",
 "cwe": [
  "CWE-79"
 ],
 "cve": [],
 "cvss": {
  "version": "3.1",
  "score": 5.5,
  "vector": "CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:L/I:L/A:N",
  "severity": "Medium"
 },
 "affected": {
  "ranges": [
   {
    "from": "1.4.0",
    "from_inclusive": true,
    "to": "1.8.4",
    "to_inclusive": false
   }
  ],
  "text": [
   "from 1.4.0 before 1.8.4"
  ]
 },
 "introduced_in": "1.4.0",
 "fixed_in": "1.8.4",
 "remediation": "Update to 1.8.4 or later.",
 "fix_released": "2026-10-26T04:41:16+00:00",
 "published": "2026-10-27T04:44:52+00:00",
 "updated": "2026-10-26T09:31:09.057492+00:00",
 "also_published_as": null,
 "references": [
  "https://wpsec.com/vuln/WPSEC-2026-1690/",
  "https://plugins.svn.wordpress.org/panorama/tags/1.8.4/",
  "https://wordpress.org/plugins/panorama/"
 ],
 "attacksurface_url": "https://attacksurface.wpsec.com/plugin/panorama",
 "source": "WPSec",
 "license": {
  "name": "CC BY 4.0",
  "url": "https://creativecommons.org/licenses/by/4.0/"
 },
 "usage": {
  "plugin": "Low",
  "affected_versions": "Low",
  "as_of": "2026-10-27"
 }
}