# Rocket Font <= 1.2.3 - Unauthenticated Stored Cross-Site Scripting via Plugin Settings

- **ID:** WPSEC-2026-1692
- **Plugin:** Rocket Font (`rocket-font`), https://wordpress.org/plugins/rocket-font/
- **Affected versions:** all versions before 2.1.2
- **Fixed in:** 2.1.2 (Update to 2.1.2 or later.)
- **Severity:** High 7.2 (CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N)
- **Weakness:** CWE-79
- **Usage among sites WPSec scans:** plugin Low, affected versions None seen (as of 2026-10-27)
- **Attack surface analysis:** https://attacksurface.wpsec.com/plugin/rocket-font
- **Fix released:** 2026-10-26
- **Published:** 2026-10-27
- **URL:** https://wpsec.com/vuln/WPSEC-2026-1692/

## Description

The rocket-font plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's settings (such as the font color, font size and class/ID selector list options) in all versions up to, and including, 1.2.3 due to insufficient input sanitization and output escaping on the settings page. Combined with the unprotected settings update handler, this makes it possible for unauthenticated attackers to inject arbitrary web scripts that execute when an administrator accesses the plugin's settings page.

## References

- https://wpsec.com/vuln/WPSEC-2026-1692/
- https://plugins.svn.wordpress.org/rocket-font/tags/2.1.2/
- https://wordpress.org/plugins/rocket-font/

Source: WPSec, https://wpsec.com/vuln/WPSEC-2026-1692/

License: CC BY 4.0 (https://creativecommons.org/licenses/by/4.0/). Free to use, share and adapt, also commercially, if you credit WPSec and link to this advisory.
