# LightBox Block <= 1.2.0 - Authenticated (Contributor+) Stored Cross-Site Scripting via Lightbox Item URLs

- **ID:** WPSEC-2026-1716
- **Plugin:** All In One Lightbox – show any media in beautiful popups (`lightbox-block`), https://wordpress.org/plugins/lightbox-block/
- **Affected versions:** all versions before 1.2.1
- **Fixed in:** 1.2.1 (Update to 1.2.1 or later.)
- **Severity:** Medium 6.4 (CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N)
- **Weakness:** CWE-79
- **Usage among sites WPSec scans:** plugin Low, affected versions Low (as of 2026-10-27)
- **Attack surface analysis:** https://attacksurface.wpsec.com/plugin/lightbox-block
- **Fix released:** 2026-10-26
- **Published:** 2026-10-27
- **URL:** https://wpsec.com/vuln/WPSEC-2026-1716/

## Description

The All In One Lightbox plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the lightbox block's item URL attributes (such as video, audio and image item URLs and iframe sources) in all versions up to, and including, 1.2.0. This is due to insufficient validation of URL schemes before the values are used as link targets opened in the lightbox and as iframe sources, allowing javascript: URLs. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page and opens the lightbox item.

## References

- https://wpsec.com/vuln/WPSEC-2026-1716/
- https://plugins.svn.wordpress.org/lightbox-block/tags/1.2.1/
- https://wordpress.org/plugins/lightbox-block/

Source: WPSec, https://wpsec.com/vuln/WPSEC-2026-1716/

License: CC BY 4.0 (https://creativecommons.org/licenses/by/4.0/). Free to use, share and adapt, also commercially, if you credit WPSec and link to this advisory.
