{
 "id": "WPSEC-2026-1718",
 "url": "https://wpsec.com/vuln/WPSEC-2026-1718/",
 "json_url": "https://wpsec.com/vuln/WPSEC-2026-1718/advisory.json",
 "markdown_url": "https://wpsec.com/vuln/WPSEC-2026-1718/index.md",
 "title": "WP2LEADS |  WordPress und KlickTipp einfach verbinden – WooCommerce und KlickTipp einfach verbinden <= 3.5.6 - Authenticated (Subscriber+) SQL Injection via Global Table Search",
 "description": "The WP2LEADS plugin for WordPress is vulnerable to SQL Injection via the table, column and order parameters of the global table search and multisearch AJAX actions in all versions up to, and including, 3.5.6. This is due to these values being placed into DESCRIBE and SELECT statements without validation against the database schema or an allowlist, combined with missing capability checks on the handlers. This makes it possible for authenticated attackers, with Subscriber-level access and above, to inject SQL and extract sensitive information from the database.",
 "plugin": {
  "slug": "wp2leads",
  "name": "WP2LEADS |  WordPress und KlickTipp einfach verbinden – WooCommerce und KlickTipp einfach verbinden",
  "full_name": "WP2LEADS |  WordPress und KlickTipp einfach verbinden – WooCommerce und KlickTipp einfach verbinden",
  "wordpress_org": "https://wordpress.org/plugins/wp2leads/",
  "advisories_url": "https://wpsec.com/vuln/plugin/wp2leads/",
  "attacksurface": "https://attacksurface.wpsec.com/plugin/wp2leads"
 },
 "type": "SQLI",
 "cwe": [
  "CWE-89"
 ],
 "cve": [],
 "cvss": {
  "version": "3.1",
  "score": 6.5,
  "vector": "CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N",
  "severity": "Medium"
 },
 "affected": {
  "ranges": [
   {
    "from": null,
    "from_inclusive": true,
    "to": "3.5.12",
    "to_inclusive": false
   }
  ],
  "text": [
   "all versions before 3.5.12"
  ]
 },
 "introduced_in": null,
 "fixed_in": "3.5.12",
 "remediation": "Update to 3.5.12 or later.",
 "fix_released": "2026-10-26T10:42:20+00:00",
 "published": "2026-10-27T10:49:10+00:00",
 "updated": "2026-10-26T13:21:18.614664+00:00",
 "also_published_as": null,
 "references": [
  "https://wpsec.com/vuln/WPSEC-2026-1718/",
  "https://plugins.svn.wordpress.org/wp2leads/tags/3.5.12/",
  "https://wordpress.org/plugins/wp2leads/"
 ],
 "attacksurface_url": "https://attacksurface.wpsec.com/plugin/wp2leads",
 "source": "WPSec",
 "license": {
  "name": "CC BY 4.0",
  "url": "https://creativecommons.org/licenses/by/4.0/"
 },
 "usage": {
  "plugin": "Low",
  "affected_versions": "Low",
  "as_of": "2026-10-27"
 }
}