# iChart – Easy Charts and Graphs <= 2.2.2 - Authenticated (Subscriber+) Sensitive Information Exposure via qcld_ai_get_chart AJAX Action

- **ID:** WPSEC-2026-1721
- **Plugin:** iChart – Easy Charts and Graphs (`ichart`), https://wordpress.org/plugins/ichart/
- **Affected versions:** all versions before 2.2.3
- **Fixed in:** 2.2.3 (Update to 2.2.3 or later.)
- **Severity:** Medium 4.3 (CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N)
- **Weakness:** CWE-639
- **Usage among sites WPSec scans:** plugin Low, affected versions Low (as of 2026-10-27)
- **Attack surface analysis:** https://attacksurface.wpsec.com/plugin/ichart
- **Fix released:** 2026-10-26
- **Published:** 2026-10-27
- **URL:** https://wpsec.com/vuln/WPSEC-2026-1721/

## Description

The iChart plugin for WordPress is vulnerable to Sensitive Information Exposure via the qcld_ai_get_chart AJAX action in all versions up to, and including, 2.2.2. This is due to a missing capability check and no post-type restriction on the user-supplied 'post_id' parameter, with only a nonce check that was exposed to all logged-in users. This makes it possible for authenticated attackers, with Subscriber-level access and above, to read chart datasets, prompts and chart type metadata stored on arbitrary posts, including unpublished charts.

## References

- https://wpsec.com/vuln/WPSEC-2026-1721/
- https://plugins.svn.wordpress.org/ichart/tags/2.2.3/
- https://wordpress.org/plugins/ichart/

Source: WPSec, https://wpsec.com/vuln/WPSEC-2026-1721/

License: CC BY 4.0 (https://creativecommons.org/licenses/by/4.0/). Free to use, share and adapt, also commercially, if you credit WPSec and link to this advisory.
