# iChart – Easy Charts and Graphs <= 2.2.2 - Authenticated (Subscriber+) Insecure Direct Object Reference to Arbitrary Post Modification via 'edit_post_id' Parameter

- **ID:** WPSEC-2026-1723
- **Plugin:** iChart – Easy Charts and Graphs (`ichart`), https://wordpress.org/plugins/ichart/
- **Affected versions:** all versions before 2.2.3
- **Fixed in:** 2.2.3 (Update to 2.2.3 or later.)
- **Severity:** Medium 4.3 (CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N)
- **Weakness:** CWE-639
- **Usage among sites WPSec scans:** plugin Low, affected versions Low (as of 2026-10-27)
- **Attack surface analysis:** https://attacksurface.wpsec.com/plugin/ichart
- **Fix released:** 2026-10-26
- **Published:** 2026-10-27
- **URL:** https://wpsec.com/vuln/WPSEC-2026-1723/

## Description

The iChart plugin for WordPress is vulnerable to Insecure Direct Object Reference via the qcld_ai_save_chart AJAX action in all versions up to, and including, 2.2.2. This is due to a missing capability check and missing validation on the user-controlled 'edit_post_id' parameter, which was passed directly to wp_update_post() and update_post_meta() with only a nonce check, and that nonce was exposed to all logged-in users. This makes it possible for authenticated attackers, with Subscriber-level access and above, to create chart posts, overwrite the title of arbitrary posts of any post type, and write chart metadata to them.

## References

- https://wpsec.com/vuln/WPSEC-2026-1723/
- https://plugins.svn.wordpress.org/ichart/tags/2.2.3/
- https://wordpress.org/plugins/ichart/

Source: WPSec, https://wpsec.com/vuln/WPSEC-2026-1723/

License: CC BY 4.0 (https://creativecommons.org/licenses/by/4.0/). Free to use, share and adapt, also commercially, if you credit WPSec and link to this advisory.
