{
 "id": "WPSEC-2026-1727",
 "url": "https://wpsec.com/vuln/WPSEC-2026-1727/",
 "json_url": "https://wpsec.com/vuln/WPSEC-2026-1727/advisory.json",
 "markdown_url": "https://wpsec.com/vuln/WPSEC-2026-1727/index.md",
 "title": "Product Import Export for WooCommerce – Import Export Product CSV Suite <= 2.6.7 - Authenticated (Shop Manager+) Server-Side Request Forgery via URL Import and Remote Product Image Import",
 "description": "The Product Import Export for WooCommerce plugin for WordPress is vulnerable to Server-Side Request Forgery via the import-from-URL feature (validate_file/import AJAX actions) and the remote product image import in all versions up to, and including, 2.6.7. This is due to the plugin fetching user-supplied URLs with wp_remote_get() and checking only that the URL ends in an allowed file extension, without rejecting private, loopback or link-local destinations, either directly or after HTTP redirects. This makes it possible for authenticated attackers with shop manager-level access and above to make web requests to arbitrary locations originating from the web application, which can be used to query and modify information from internal services.",
 "plugin": {
  "slug": "product-import-export-for-woo",
  "name": "Product Import Export for WooCommerce – Import Export Product CSV Suite",
  "full_name": "Product Import Export for WooCommerce – CSV Product Importer & Exporter",
  "wordpress_org": "https://wordpress.org/plugins/product-import-export-for-woo/",
  "advisories_url": "https://wpsec.com/vuln/plugin/product-import-export-for-woo/",
  "attacksurface": "https://attacksurface.wpsec.com/plugin/product-import-export-for-woo"
 },
 "type": "SSRF",
 "cwe": [
  "CWE-918"
 ],
 "cve": [],
 "cvss": {
  "version": "3.1",
  "score": 5.5,
  "vector": "CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:L/I:L/A:N",
  "severity": "Medium"
 },
 "affected": {
  "ranges": [
   {
    "from": null,
    "from_inclusive": true,
    "to": "2.6.8",
    "to_inclusive": false
   }
  ],
  "text": [
   "all versions before 2.6.8"
  ]
 },
 "introduced_in": null,
 "fixed_in": "2.6.8",
 "remediation": "Update to 2.6.8 or later.",
 "fix_released": "2026-10-26T11:18:54+00:00",
 "published": "2026-10-27T11:50:51+00:00",
 "updated": "2026-10-26T13:21:09.968111+00:00",
 "also_published_as": null,
 "references": [
  "https://wpsec.com/vuln/WPSEC-2026-1727/",
  "https://plugins.svn.wordpress.org/product-import-export-for-woo/tags/2.6.8/",
  "https://wordpress.org/plugins/product-import-export-for-woo/"
 ],
 "attacksurface_url": "https://attacksurface.wpsec.com/plugin/product-import-export-for-woo",
 "source": "WPSec",
 "license": {
  "name": "CC BY 4.0",
  "url": "https://creativecommons.org/licenses/by/4.0/"
 },
 "usage": {
  "plugin": "Low",
  "affected_versions": "Low",
  "as_of": "2026-10-27"
 }
}