# Co-Authors Plus <= 4.1.2 - Authenticated (Contributor+) Missing Authorization to Post Co-Author Modification via REST API and tax_input

- **ID:** WPSEC-2026-1746
- **Plugin:** Co-Authors Plus (`co-authors-plus`), https://wordpress.org/plugins/co-authors-plus/
- **Affected versions:** all versions before 4.1.3
- **Fixed in:** 4.1.3 (Update to 4.1.3 or later.)
- **Severity:** Medium 4.3 (CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N)
- **Weakness:** CWE-862
- **Usage among sites WPSec scans:** plugin Medium, affected versions Medium (as of 2026-10-27)
- **Attack surface analysis:** https://attacksurface.wpsec.com/plugin/co-authors-plus
- **Fix released:** 2026-10-26
- **Published:** 2026-10-27
- **URL:** https://wpsec.com/vuln/WPSEC-2026-1746/

## Description

The Co-Authors Plus plugin for WordPress is vulnerable to unauthorized modification of data via the REST API 'coauthors' parameter and the 'tax_input' post field in all versions up to, and including, 4.1.2, due to the author taxonomy using WordPress's default assign_terms capability (edit_posts) instead of the plugin's set-authors check (edit_others_posts by default). This makes it possible for authenticated attackers with Contributor-level access and above, who are not permitted to set authors, to change or clear the co-authors (bylines) of posts they can edit, for example crediting their own posts to other users.

## References

- https://wpsec.com/vuln/WPSEC-2026-1746/
- https://plugins.svn.wordpress.org/co-authors-plus/tags/4.1.3/
- https://wordpress.org/plugins/co-authors-plus/

Source: WPSec, https://wpsec.com/vuln/WPSEC-2026-1746/

License: CC BY 4.0 (https://creativecommons.org/licenses/by/4.0/). Free to use, share and adapt, also commercially, if you credit WPSec and link to this advisory.
