# Co-Authors Plus <= 4.1.2 - Authenticated (Subscriber+) Improper Authorization to Co-Authored Post Editing

- **ID:** WPSEC-2026-1747
- **Plugin:** Co-Authors Plus (`co-authors-plus`), https://wordpress.org/plugins/co-authors-plus/
- **Affected versions:** all versions before 4.1.3
- **Fixed in:** 4.1.3 (Update to 4.1.3 or later.)
- **Severity:** Medium 4.2 (CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:L/A:N)
- **Weakness:** CWE-863
- **Usage among sites WPSec scans:** plugin Medium, affected versions Medium (as of 2026-10-27)
- **Attack surface analysis:** https://attacksurface.wpsec.com/plugin/co-authors-plus
- **Fix released:** 2026-10-26
- **Published:** 2026-10-27
- **URL:** https://wpsec.com/vuln/WPSEC-2026-1747/

## Description

The Co-Authors Plus plugin for WordPress is vulnerable to improper authorization via the co-author capability filter in all versions up to, and including, 4.1.2, due to the user_has_cap filter granting the edit_others_posts capability to any user credited as a co-author of a post, whatever their own role allows. This makes it possible for authenticated attackers with Subscriber-level access and above who are credited as a co-author on a post (for example a user demoted after being credited) to view and edit draft and pending posts their role would not otherwise let them edit.

## References

- https://wpsec.com/vuln/WPSEC-2026-1747/
- https://plugins.svn.wordpress.org/co-authors-plus/tags/4.1.3/
- https://wordpress.org/plugins/co-authors-plus/

Source: WPSec, https://wpsec.com/vuln/WPSEC-2026-1747/

License: CC BY 4.0 (https://creativecommons.org/licenses/by/4.0/). Free to use, share and adapt, also commercially, if you credit WPSec and link to this advisory.
