{
 "id": "WPSEC-2026-1750",
 "url": "https://wpsec.com/vuln/WPSEC-2026-1750/",
 "json_url": "https://wpsec.com/vuln/WPSEC-2026-1750/advisory.json",
 "markdown_url": "https://wpsec.com/vuln/WPSEC-2026-1750/index.md",
 "title": "Co-Authors, Multiple Authors and Guest Authors in an Author Box with PublishPress Authors <= 4.17.0 - Authenticated (Contributor+) Stored Cross-Site Scripting via Author Data Shortcode 'separator' Attribute",
 "description": "The Co-Authors, Multiple Authors and Guest Authors in an Author Box with PublishPress Authors plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'separator' attribute of the author data shortcode in all versions up to, and including, 4.17.0 due to insufficient input sanitization and output escaping when joining author field values. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.",
 "plugin": {
  "slug": "publishpress-authors",
  "name": "Co-Authors, Multiple Authors and Guest Authors in an Author Box with PublishPress Authors",
  "full_name": "Co-Authors, Multiple Authors and Guest Authors in an Author Box with PublishPress Authors",
  "wordpress_org": "https://wordpress.org/plugins/publishpress-authors/",
  "advisories_url": "https://wpsec.com/vuln/plugin/publishpress-authors/",
  "attacksurface": "https://attacksurface.wpsec.com/plugin/publishpress-authors"
 },
 "type": "XSS",
 "cwe": [
  "CWE-79"
 ],
 "cve": [],
 "cvss": {
  "version": "3.1",
  "score": 6.4,
  "vector": "CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N",
  "severity": "Medium"
 },
 "affected": {
  "ranges": [
   {
    "from": null,
    "from_inclusive": true,
    "to": "4.18.0",
    "to_inclusive": false
   }
  ],
  "text": [
   "all versions before 4.18.0"
  ]
 },
 "introduced_in": null,
 "fixed_in": "4.18.0",
 "remediation": "Update to 4.18.0 or later.",
 "fix_released": "2026-10-26T13:28:53+00:00",
 "published": "2026-10-27T13:53:32+00:00",
 "updated": "2026-10-27T13:39:39.642999+00:00",
 "also_published_as": null,
 "references": [
  "https://wpsec.com/vuln/WPSEC-2026-1750/",
  "https://plugins.svn.wordpress.org/publishpress-authors/tags/4.18.0/",
  "https://wordpress.org/plugins/publishpress-authors/"
 ],
 "attacksurface_url": "https://attacksurface.wpsec.com/plugin/publishpress-authors",
 "source": "WPSec",
 "license": {
  "name": "CC BY 4.0",
  "url": "https://creativecommons.org/licenses/by/4.0/"
 },
 "usage": {
  "plugin": "Low",
  "affected_versions": "Low",
  "as_of": "2026-10-27"
 }
}