# Co-Authors, Multiple Authors and Guest Authors in an Author Box with PublishPress Authors <= 4.17.0 - Authenticated (Contributor+) Stored Cross-Site Scripting via Authors List 'layout' Shortcode Attribute

- **ID:** WPSEC-2026-1751
- **Plugin:** Co-Authors, Multiple Authors and Guest Authors in an Author Box with PublishPress Authors (`publishpress-authors`), https://wordpress.org/plugins/publishpress-authors/
- **Affected versions:** all versions before 4.18.0
- **Fixed in:** 4.18.0 (Update to 4.18.0 or later.)
- **Severity:** Medium 6.4 (CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N)
- **Weakness:** CWE-79
- **Usage among sites WPSec scans:** plugin Low, affected versions Low (as of 2026-10-27)
- **Attack surface analysis:** https://attacksurface.wpsec.com/plugin/publishpress-authors
- **Fix released:** 2026-10-26
- **Published:** 2026-10-27
- **URL:** https://wpsec.com/vuln/WPSEC-2026-1751/

## Description

The Co-Authors, Multiple Authors and Guest Authors in an Author Box with PublishPress Authors plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'layout' attribute used by the authors list rendering in all versions up to, and including, 4.17.0 due to the value being placed into an inline style block without sanitization. This makes it possible for authenticated attackers, with contributor-level access and above, to break out of the style element and inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

## References

- https://wpsec.com/vuln/WPSEC-2026-1751/
- https://plugins.svn.wordpress.org/publishpress-authors/tags/4.18.0/
- https://wordpress.org/plugins/publishpress-authors/

Source: WPSec, https://wpsec.com/vuln/WPSEC-2026-1751/

License: CC BY 4.0 (https://creativecommons.org/licenses/by/4.0/). Free to use, share and adapt, also commercially, if you credit WPSec and link to this advisory.
