# WP GPX Maps <= 1.7.11 - Unauthenticated Reflected Cross-Site Scripting via 'nggalleries' and 'ngimages' Parameters

- **ID:** WPSEC-2026-1767
- **Plugin:** WP GPX Maps (`wp-gpx-maps`), https://wordpress.org/plugins/wp-gpx-maps/
- **Affected versions:** all versions before 1.8.00
- **Fixed in:** 1.8.00 (Update to 1.8.00 or later.)
- **Severity:** Medium 6.1 (CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N)
- **Weakness:** CWE-79
- **Usage among sites WPSec scans:** plugin Low, affected versions Low (as of 2026-10-27)
- **Attack surface analysis:** https://attacksurface.wpsec.com/plugin/wp-gpx-maps
- **Fix released:** 2026-10-26
- **Published:** 2026-10-27
- **URL:** https://wpsec.com/vuln/WPSEC-2026-1767/

## Description

The WP GPX Maps plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the 'nggalleries' and 'ngimages' parameters in all versions up to, and including, 1.7.11. This is due to shortcode parameters falling back to values from the page URL query string and being output inside a JavaScript array literal with only esc_js(), which does not prevent injection of raw JavaScript expressions. This makes it possible for unauthenticated attackers to inject arbitrary web scripts that execute when a user clicks a crafted link to a page containing the [sgpx] shortcode.

## References

- https://wpsec.com/vuln/WPSEC-2026-1767/
- https://plugins.svn.wordpress.org/wp-gpx-maps/tags/1.8.00/
- https://wordpress.org/plugins/wp-gpx-maps/

Source: WPSec, https://wpsec.com/vuln/WPSEC-2026-1767/

License: CC BY 4.0 (https://creativecommons.org/licenses/by/4.0/). Free to use, share and adapt, also commercially, if you credit WPSec and link to this advisory.
