# WP GPX Maps <= 1.7.11 - Authenticated (Contributor+) Stored Cross-Site Scripting via 'nggalleries' and 'ngimages' Shortcode Attributes

- **ID:** WPSEC-2026-1770
- **Plugin:** WP GPX Maps (`wp-gpx-maps`), https://wordpress.org/plugins/wp-gpx-maps/
- **Affected versions:** all versions before 1.8.00
- **Fixed in:** 1.8.00 (Update to 1.8.00 or later.)
- **Severity:** Medium 6.4 (CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N)
- **Weakness:** CWE-79
- **Usage among sites WPSec scans:** plugin Low, affected versions Low (as of 2026-10-27)
- **Attack surface analysis:** https://attacksurface.wpsec.com/plugin/wp-gpx-maps
- **Fix released:** 2026-10-26
- **Published:** 2026-10-27
- **URL:** https://wpsec.com/vuln/WPSEC-2026-1770/

## Description

The WP GPX Maps plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'nggalleries' and 'ngimages' attributes of the [sgpx] shortcode in all versions up to, and including, 1.7.11. This is due to insufficient input sanitization, as the values are placed inside a JavaScript array literal wrapped only in esc_js(), which does not prevent raw JavaScript expressions. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

## References

- https://wpsec.com/vuln/WPSEC-2026-1770/
- https://plugins.svn.wordpress.org/wp-gpx-maps/tags/1.8.00/
- https://wordpress.org/plugins/wp-gpx-maps/

Source: WPSec, https://wpsec.com/vuln/WPSEC-2026-1770/

License: CC BY 4.0 (https://creativecommons.org/licenses/by/4.0/). Free to use, share and adapt, also commercially, if you credit WPSec and link to this advisory.
