{
 "id": "WPSEC-2026-1774",
 "url": "https://wpsec.com/vuln/WPSEC-2026-1774/",
 "json_url": "https://wpsec.com/vuln/WPSEC-2026-1774/advisory.json",
 "markdown_url": "https://wpsec.com/vuln/WPSEC-2026-1774/index.md",
 "title": "Appointment Booking Calendar <= 1.4.06 - Unauthenticated Payment Bypass via Insufficient PayPal IPN Verification",
 "description": "The Appointment Booking Calendar plugin for WordPress is vulnerable to payment bypass via the PayPal IPN handler (cpabc_ipncheck) in all versions up to, and including, 1.4.06, due to insufficient verification of payment notifications. The handler took the booking ID from the cpabc_ipncheck URL parameter, which is not part of the message PayPal verifies. It did not check the receiver e-mail, currency, amount or payment status (pending eCheck payments were accepted), and it did not stop a transaction ID from being used again. This makes it possible for unauthenticated attackers to mark arbitrary pending bookings as paid and confirmed, without paying the site owner, by sending a genuine PayPal-verified IPN message from an unrelated or minimal payment against any booking ID. Because the confirmation e-mail is also sent to the payer_email in that message, attackers can also receive other customers' booking details (name, e-mail, phone and comments).",
 "plugin": {
  "slug": "appointment-booking-calendar",
  "name": "Appointment Booking Calendar",
  "full_name": "Appointment Booking Calendar",
  "wordpress_org": "https://wordpress.org/plugins/appointment-booking-calendar/",
  "advisories_url": "https://wpsec.com/vuln/plugin/appointment-booking-calendar/",
  "attacksurface": "https://attacksurface.wpsec.com/plugin/appointment-booking-calendar"
 },
 "type": "BYPASS",
 "cwe": [
  "CWE-345"
 ],
 "cve": [],
 "cvss": {
  "version": "3.1",
  "score": 6.5,
  "vector": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N",
  "severity": "Medium"
 },
 "affected": {
  "ranges": [
   {
    "from": null,
    "from_inclusive": true,
    "to": "1.4.07",
    "to_inclusive": false
   }
  ],
  "text": [
   "all versions before 1.4.07"
  ]
 },
 "introduced_in": null,
 "fixed_in": "1.4.07",
 "remediation": "Update to 1.4.07 or later.",
 "fix_released": "2026-10-26T17:38:07+00:00",
 "published": "2026-10-27T17:47:54+00:00",
 "updated": "2026-10-27T13:05:34.429630+00:00",
 "also_published_as": null,
 "references": [
  "https://wpsec.com/vuln/WPSEC-2026-1774/",
  "https://plugins.svn.wordpress.org/appointment-booking-calendar/tags/1.4.07/",
  "https://wordpress.org/plugins/appointment-booking-calendar/"
 ],
 "attacksurface_url": "https://attacksurface.wpsec.com/plugin/appointment-booking-calendar",
 "source": "WPSec",
 "license": {
  "name": "CC BY 4.0",
  "url": "https://creativecommons.org/licenses/by/4.0/"
 },
 "usage": {
  "plugin": "Low",
  "affected_versions": "None seen",
  "as_of": "2026-10-27"
 }
}