{
 "id": "WPSEC-2026-1787",
 "url": "https://wpsec.com/vuln/WPSEC-2026-1787/",
 "json_url": "https://wpsec.com/vuln/WPSEC-2026-1787/advisory.json",
 "markdown_url": "https://wpsec.com/vuln/WPSEC-2026-1787/index.md",
 "title": "Safe SVG <= 2.5.1 - Authenticated (Author+) Stored Cross-Site Scripting via SVG File Upload",
 "description": "The Safe SVG plugin for WordPress is vulnerable to Stored Cross-Site Scripting via SVG file uploads in all versions up to, and including, 2.5.1. This is due to insufficient sanitization in the bundled enshrined/svg-sanitize library (1.0.0), which kept the attributeName attribute on allowed SMIL animation elements such as animateTransform, so an animation could rewrite a link's href into a javascript: URI after sanitization. This makes it possible for authenticated attackers with Author-level access and above, or any role allowed to upload SVG files, to upload SVG files that execute arbitrary web scripts when a user clicks a link in the SVG in a browser that allows this retargeting, such as Safari, whether the file is opened directly or shown inline by the Safe SVG block.",
 "plugin": {
  "slug": "safe-svg",
  "name": "Safe SVG",
  "full_name": "Safe SVG",
  "wordpress_org": "https://wordpress.org/plugins/safe-svg/",
  "advisories_url": "https://wpsec.com/vuln/plugin/safe-svg/",
  "attacksurface": "https://attacksurface.wpsec.com/plugin/safe-svg"
 },
 "type": "XSS",
 "cwe": [
  "CWE-79"
 ],
 "cve": [],
 "cvss": {
  "version": "3.1",
  "score": 5.4,
  "vector": "CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N",
  "severity": "Medium"
 },
 "affected": {
  "ranges": [
   {
    "from": null,
    "from_inclusive": true,
    "to": "2.5.2",
    "to_inclusive": false
   }
  ],
  "text": [
   "all versions before 2.5.2"
  ]
 },
 "introduced_in": null,
 "fixed_in": "2.5.2",
 "remediation": "Update to 2.5.2 or later.",
 "fix_released": "2026-10-26T22:32:07+00:00",
 "published": "2026-10-27T22:54:07+00:00",
 "updated": "2026-10-27T13:39:21.789331+00:00",
 "also_published_as": null,
 "references": [
  "https://wpsec.com/vuln/WPSEC-2026-1787/",
  "https://plugins.svn.wordpress.org/safe-svg/tags/2.5.2/",
  "https://wordpress.org/plugins/safe-svg/"
 ],
 "attacksurface_url": "https://attacksurface.wpsec.com/plugin/safe-svg",
 "source": "WPSec",
 "license": {
  "name": "CC BY 4.0",
  "url": "https://creativecommons.org/licenses/by/4.0/"
 },
 "usage": {
  "plugin": "High",
  "affected_versions": "High",
  "as_of": "2026-10-27"
 }
}