{
 "id": "WPSEC-2026-1791",
 "url": "https://wpsec.com/vuln/WPSEC-2026-1791/",
 "json_url": "https://wpsec.com/vuln/WPSEC-2026-1791/advisory.json",
 "markdown_url": "https://wpsec.com/vuln/WPSEC-2026-1791/index.md",
 "title": "PowerPack Addons for Elementor (Free Widgets, Extensions and Templates) <= 3.1.2 - Authenticated (Contributor+) Stored Cross-Site Scripting via Hotspots and Pricing Table Tooltip Size",
 "description": "The PowerPack Addons for Elementor (Free Widgets, Extensions and Templates) plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the tooltip size setting of the Image Hotspots and Pricing Table widgets in all versions up to, and including, 3.1.2, due to the value not being validated against its allowed options before the front-end script concatenates it into the tooltip's HTML class attribute. This makes it possible for authenticated attackers with contributor-level access and above to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page and the tooltip is displayed.",
 "plugin": {
  "slug": "powerpack-lite-for-elementor",
  "name": "PowerPack Addons for Elementor (Free Widgets, Extensions and Templates)",
  "full_name": "PowerPack Addons for Elementor (Free Widgets, Extensions and Templates)",
  "wordpress_org": "https://wordpress.org/plugins/powerpack-lite-for-elementor/",
  "advisories_url": "https://wpsec.com/vuln/plugin/powerpack-lite-for-elementor/",
  "attacksurface": "https://attacksurface.wpsec.com/plugin/powerpack-lite-for-elementor"
 },
 "type": "XSS",
 "cwe": [
  "CWE-79"
 ],
 "cve": [],
 "cvss": {
  "version": "3.1",
  "score": 6.4,
  "vector": "CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N",
  "severity": "Medium"
 },
 "affected": {
  "ranges": [
   {
    "from": null,
    "from_inclusive": true,
    "to": "3.1.3",
    "to_inclusive": false
   }
  ],
  "text": [
   "all versions before 3.1.3"
  ]
 },
 "introduced_in": null,
 "fixed_in": "3.1.3",
 "remediation": "Update to 3.1.3 or later.",
 "fix_released": "2026-10-27T00:52:29+00:00",
 "published": "2026-10-28T01:40:42+00:00",
 "updated": "2026-10-27T13:39:28.994472+00:00",
 "also_published_as": null,
 "references": [
  "https://wpsec.com/vuln/WPSEC-2026-1791/",
  "https://plugins.svn.wordpress.org/powerpack-lite-for-elementor/tags/3.1.3/",
  "https://wordpress.org/plugins/powerpack-lite-for-elementor/"
 ],
 "attacksurface_url": "https://attacksurface.wpsec.com/plugin/powerpack-lite-for-elementor",
 "source": "WPSec",
 "license": {
  "name": "CC BY 4.0",
  "url": "https://creativecommons.org/licenses/by/4.0/"
 },
 "usage": {
  "plugin": "Medium",
  "affected_versions": "Medium",
  "as_of": "2026-10-27"
 }
}