{
 "id": "WPSEC-2026-1792",
 "url": "https://wpsec.com/vuln/WPSEC-2026-1792/",
 "json_url": "https://wpsec.com/vuln/WPSEC-2026-1792/advisory.json",
 "markdown_url": "https://wpsec.com/vuln/WPSEC-2026-1792/index.md",
 "title": "CMB2 <= 2.13.4 - Authenticated (Contributor+) Stored Cross-Site Scripting via Grouped WYSIWYG Field",
 "description": "The CMB2 plugin for WordPress is vulnerable to Stored Cross-Site Scripting via WYSIWYG fields inside a repeatable group in versions 2.2.3 up to, and including, 2.13.4, due to insufficient output escaping of the saved field value. The value was printed into the placeholder textarea without esc_textarea and then inserted unescaped into the editor's JavaScript template, so entity-encoded markup that passes wp_kses_post is decoded and rendered as live HTML. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts that execute when another user, such as an administrator, opens the edit screen of an affected post that uses a grouped WYSIWYG field.",
 "plugin": {
  "slug": "cmb2",
  "name": "CMB2",
  "full_name": "CMB2",
  "wordpress_org": "https://wordpress.org/plugins/cmb2/",
  "advisories_url": "https://wpsec.com/vuln/plugin/cmb2/",
  "attacksurface": "https://attacksurface.wpsec.com/plugin/cmb2"
 },
 "type": "XSS",
 "cwe": [
  "CWE-79"
 ],
 "cve": [],
 "cvss": {
  "version": "3.1",
  "score": 6.4,
  "vector": "CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N",
  "severity": "Medium"
 },
 "affected": {
  "ranges": [
   {
    "from": "2.2.3",
    "from_inclusive": true,
    "to": "2.13.5",
    "to_inclusive": false
   }
  ],
  "text": [
   "from 2.2.3 before 2.13.5"
  ]
 },
 "introduced_in": "2.2.3",
 "fixed_in": "2.13.5",
 "remediation": "Update to 2.13.5 or later.",
 "fix_released": "2026-10-27T01:49:19+00:00",
 "published": "2026-10-28T02:42:02+00:00",
 "updated": "2026-10-27T13:05:38.032140+00:00",
 "also_published_as": {
  "source": "wordfence",
  "cve": [
   "CVE-2026-116761"
  ],
  "published": "2026-10-27T18:41:44+00:00"
 },
 "references": [
  "https://wpsec.com/vuln/WPSEC-2026-1792/",
  "https://plugins.svn.wordpress.org/cmb2/tags/2.13.5/",
  "https://wordpress.org/plugins/cmb2/"
 ],
 "attacksurface_url": "https://attacksurface.wpsec.com/plugin/cmb2",
 "source": "WPSec",
 "license": {
  "name": "CC BY 4.0",
  "url": "https://creativecommons.org/licenses/by/4.0/"
 },
 "usage": {
  "plugin": "Low",
  "affected_versions": "None seen",
  "as_of": "2026-10-27"
 }
}