# CMB2 <= 2.13.4 - Authenticated (Contributor+) Stored Cross-Site Scripting via Grouped WYSIWYG Field

- **ID:** WPSEC-2026-1792
- **Plugin:** CMB2 (`cmb2`), https://wordpress.org/plugins/cmb2/
- **Affected versions:** from 2.2.3 before 2.13.5
- **Fixed in:** 2.13.5 (Update to 2.13.5 or later.)
- **Severity:** Medium 6.4 (CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N)
- **Weakness:** CWE-79
- **Usage among sites WPSec scans:** plugin Low, affected versions None seen (as of 2026-10-27)
- **Attack surface analysis:** https://attacksurface.wpsec.com/plugin/cmb2
- **Fix released:** 2026-10-27
- **Published:** 2026-10-28
- **URL:** https://wpsec.com/vuln/WPSEC-2026-1792/

## Description

The CMB2 plugin for WordPress is vulnerable to Stored Cross-Site Scripting via WYSIWYG fields inside a repeatable group in versions 2.2.3 up to, and including, 2.13.4, due to insufficient output escaping of the saved field value. The value was printed into the placeholder textarea without esc_textarea and then inserted unescaped into the editor's JavaScript template, so entity-encoded markup that passes wp_kses_post is decoded and rendered as live HTML. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts that execute when another user, such as an administrator, opens the edit screen of an affected post that uses a grouped WYSIWYG field.

Also published later by wordfence as CVE-2026-116761.

## References

- https://wpsec.com/vuln/WPSEC-2026-1792/
- https://plugins.svn.wordpress.org/cmb2/tags/2.13.5/
- https://wordpress.org/plugins/cmb2/

Source: WPSec, https://wpsec.com/vuln/WPSEC-2026-1792/

License: CC BY 4.0 (https://creativecommons.org/licenses/by/4.0/). Free to use, share and adapt, also commercially, if you credit WPSec and link to this advisory.
