# AI Engine <= 3.8.7 - Authenticated (Editor+) Sensitive Information Exposure via Log Endpoints

- **ID:** WPSEC-2026-1803
- **Plugin:** AI Engine – MCP Server & AI Chatbot for WordPress, with Claude, ChatGPT & Gemini (`ai-engine`), https://wordpress.org/plugins/ai-engine/
- **Affected versions:** all versions before 3.8.8
- **Fixed in:** 3.8.8 (Update to 3.8.8 or later.)
- **Severity:** Low 3.3 (CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:L/I:L/A:N)
- **Weakness:** CWE-284
- **Usage among sites WPSec scans:** plugin Low, affected versions Low (as of 2026-10-28)
- **Attack surface analysis:** https://attacksurface.wpsec.com/plugin/ai-engine
- **Fix released:** 2026-10-27
- **Published:** 2026-10-28
- **URL:** https://wpsec.com/vuln/WPSEC-2026-1803/

## Description

The AI Engine plugin for WordPress is vulnerable to Sensitive Information Exposure via the /mwai/v1/get_logs and /mwai/v1/clear_logs REST endpoints in all versions up to, and including, 3.8.7, due to the endpoints checking can_access_features() (Editor or Administrator) instead of the settings capability (manage_options). This makes it possible for authenticated attackers, with Editor-level access and above, to read the plugin's debug log, which can contain chat messages and request details from other users, and to delete it. The log is only written when Dev Tools and server debug mode are enabled.

## References

- https://wpsec.com/vuln/WPSEC-2026-1803/
- https://plugins.svn.wordpress.org/ai-engine/tags/3.8.8/
- https://wordpress.org/plugins/ai-engine/

Source: WPSec, https://wpsec.com/vuln/WPSEC-2026-1803/

License: CC BY 4.0 (https://creativecommons.org/licenses/by/4.0/). Free to use, share and adapt, also commercially, if you credit WPSec and link to this advisory.
