{
 "id": "WPSEC-2026-1806",
 "url": "https://wpsec.com/vuln/WPSEC-2026-1806/",
 "json_url": "https://wpsec.com/vuln/WPSEC-2026-1806/advisory.json",
 "markdown_url": "https://wpsec.com/vuln/WPSEC-2026-1806/index.md",
 "title": "WP Job Portal – AI-Powered Recruitment System for Company or Job Board website <= 2.7.0 - Authenticated (Subscriber+) Stored Cross-Site Scripting via Job Structured Data (JSON-LD)",
 "description": "The WP Job Portal plugin for WordPress is vulnerable to Stored Cross-Site Scripting via job fields output in the Google job schema JSON-LD block in all versions up to, and including, 2.7.0. This is due to insufficient input sanitization and output escaping: job values were stripped of tags before HTML entities were decoded, turning entity-encoded markup such as '&lt;/script&gt;' into live tags, and the result was JSON-encoded without JSON_HEX_TAG inside a <script type=\"application/ld+json\"> element. This makes it possible for authenticated attackers with subscriber-level access or higher who can post jobs, such as registered employers, to inject arbitrary web scripts that execute whenever a user visits the affected job page.",
 "plugin": {
  "slug": "wp-job-portal",
  "name": "WP Job Portal – AI-Powered Recruitment System for Company or Job Board website",
  "full_name": "WP Job Portal – AI-Powered Recruitment System for Company or Job Board website",
  "wordpress_org": "https://wordpress.org/plugins/wp-job-portal/",
  "advisories_url": "https://wpsec.com/vuln/plugin/wp-job-portal/",
  "attacksurface": "https://attacksurface.wpsec.com/plugin/wp-job-portal"
 },
 "type": "XSS",
 "cwe": [
  "CWE-79"
 ],
 "cve": [],
 "cvss": {
  "version": "3.1",
  "score": 6.4,
  "vector": "CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N",
  "severity": "Medium"
 },
 "affected": {
  "ranges": [
   {
    "from": null,
    "from_inclusive": true,
    "to": "2.7.1",
    "to_inclusive": false
   }
  ],
  "text": [
   "all versions before 2.7.1"
  ]
 },
 "introduced_in": null,
 "fixed_in": "2.7.1",
 "remediation": "Update to 2.7.1 or later.",
 "fix_released": "2026-10-27T05:46:18+00:00",
 "published": "2026-10-28T05:46:21+00:00",
 "updated": "2026-10-27T13:05:17.217955+00:00",
 "also_published_as": null,
 "references": [
  "https://wpsec.com/vuln/WPSEC-2026-1806/",
  "https://plugins.svn.wordpress.org/wp-job-portal/tags/2.7.1/",
  "https://wordpress.org/plugins/wp-job-portal/"
 ],
 "attacksurface_url": "https://attacksurface.wpsec.com/plugin/wp-job-portal",
 "source": "WPSec",
 "license": {
  "name": "CC BY 4.0",
  "url": "https://creativecommons.org/licenses/by/4.0/"
 },
 "usage": {
  "plugin": "Low",
  "affected_versions": "Low",
  "as_of": "2026-10-28"
 }
}