# Parallax Slider Block <= 1.2.8 - Authenticated (Contributor+) Stored Cross-Site Scripting via Slide Button Link

- **ID:** WPSEC-2026-1811
- **Plugin:** Parallax Slider Block (`parallax-slider-block`), https://wordpress.org/plugins/parallax-slider-block/
- **Affected versions:** all versions before 1.2.9
- **Fixed in:** 1.2.9 (Update to 1.2.9 or later.)
- **Severity:** Medium 5.4 (CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N)
- **Weakness:** CWE-79
- **Usage among sites WPSec scans:** plugin Low, affected versions None seen (as of 2026-10-28)
- **Attack surface analysis:** https://attacksurface.wpsec.com/plugin/parallax-slider-block
- **Fix released:** 2026-10-27
- **Published:** 2026-10-28
- **URL:** https://wpsec.com/vuln/WPSEC-2026-1811/

## Description

The Parallax Slider Block plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the slide button link ('data-link' attribute) in all versions up to, and including, 1.2.8, due to insufficient sanitization of the link before it is passed to window.open(): only the first exact lowercase occurrence of 'javascript:' is removed, so mixed-case, repeated or otherwise obfuscated javascript: URIs, as well as vbscript: and data: URIs, are still opened. This makes it possible for authenticated attackers with contributor-level access and above to inject arbitrary web scripts that execute when a user, including an administrator, clicks the slide button.

## References

- https://wpsec.com/vuln/WPSEC-2026-1811/
- https://plugins.svn.wordpress.org/parallax-slider-block/tags/1.2.9/
- https://wordpress.org/plugins/parallax-slider-block/

Source: WPSec, https://wpsec.com/vuln/WPSEC-2026-1811/

License: CC BY 4.0 (https://creativecommons.org/licenses/by/4.0/). Free to use, share and adapt, also commercially, if you credit WPSec and link to this advisory.
