# EasyJobs <= 2.8.4 - Unauthenticated Stored Cross-Site Scripting via Malicious PDF Resume

- **ID:** WPSEC-2026-1828
- **Plugin:** easy.jobs – AI powered Job Listing, Job Board, Career Page, Recruitment & Hiring Solution (`easyjobs`), https://wordpress.org/plugins/easyjobs/
- **Affected versions:** from 2.8.1 before 2.8.5
- **Fixed in:** 2.8.5 (Update to 2.8.5 or later.)
- **Severity:** Medium 6.1 (CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N)
- **Weakness:** CWE-79
- **Usage among sites WPSec scans:** plugin Low, affected versions None seen (as of 2026-10-28)
- **Attack surface analysis:** https://attacksurface.wpsec.com/plugin/easyjobs
- **Fix released:** 2026-10-27
- **Published:** 2026-10-28
- **URL:** https://wpsec.com/vuln/WPSEC-2026-1828/

## Description

The easy.jobs plugin for WordPress is vulnerable to Stored Cross-Site Scripting via candidate resume PDFs in all versions up to, and including, 2.8.4, due to the candidate details screen rendering resumes with a bundled copy of pdf.js 3.11.174, which is affected by CVE-2024-4367, opened with default options (font evaluation enabled). This makes it possible for unauthenticated attackers who apply to a job with a crafted PDF resume to execute arbitrary scripts in an administrator's browser when the administrator views the candidate's resume in wp-admin.

## References

- https://wpsec.com/vuln/WPSEC-2026-1828/
- https://plugins.svn.wordpress.org/easyjobs/tags/2.8.5/
- https://wordpress.org/plugins/easyjobs/

Source: WPSec, https://wpsec.com/vuln/WPSEC-2026-1828/

License: CC BY 4.0 (https://creativecommons.org/licenses/by/4.0/). Free to use, share and adapt, also commercially, if you credit WPSec and link to this advisory.
