{
 "id": "WPSEC-2026-1833",
 "url": "https://wpsec.com/vuln/WPSEC-2026-1833/",
 "json_url": "https://wpsec.com/vuln/WPSEC-2026-1833/advisory.json",
 "markdown_url": "https://wpsec.com/vuln/WPSEC-2026-1833/index.md",
 "title": "Mollie Payments for WooCommerce <= 8.1.11 - Unauthenticated Improper Input Validation to Restricted Product Purchase via PayPal Express Button",
 "description": "The Mollie Payments for WooCommerce plugin for WordPress is vulnerable to Improper Input Validation via the PayPal express button AJAX handlers in all versions up to, and including, 8.1.11, due to the product-page handler building a WooCommerce order from any product ID and quantity posted by the client, without checking that the product is published, purchasable, in stock, has enough stock, or is a product the button is offered for. This makes it possible for unauthenticated attackers to create and pay orders for private or draft products, out-of-stock items, or products the PayPal button is not shown for, bypassing the store's purchase restrictions. Exploitation requires the PayPal express button to be enabled.",
 "plugin": {
  "slug": "mollie-payments-for-woocommerce",
  "name": "Mollie Payments for WooCommerce",
  "full_name": "Mollie Payments for WooCommerce",
  "wordpress_org": "https://wordpress.org/plugins/mollie-payments-for-woocommerce/",
  "advisories_url": "https://wpsec.com/vuln/plugin/mollie-payments-for-woocommerce/",
  "attacksurface": "https://attacksurface.wpsec.com/plugin/mollie-payments-for-woocommerce"
 },
 "type": "BYPASS",
 "cwe": [
  "CWE-20"
 ],
 "cve": [],
 "cvss": {
  "version": "3.1",
  "score": 5.3,
  "vector": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N",
  "severity": "Medium"
 },
 "affected": {
  "ranges": [
   {
    "from": null,
    "from_inclusive": true,
    "to": "8.2.0",
    "to_inclusive": false
   }
  ],
  "text": [
   "all versions before 8.2.0"
  ]
 },
 "introduced_in": null,
 "fixed_in": "8.2.0",
 "remediation": "Update to 8.2.0 or later.",
 "fix_released": "2026-10-27T11:01:15+00:00",
 "published": "2026-10-28T11:50:08+00:00",
 "updated": "2026-10-28T09:11:48.993386+00:00",
 "also_published_as": null,
 "references": [
  "https://wpsec.com/vuln/WPSEC-2026-1833/",
  "https://plugins.svn.wordpress.org/mollie-payments-for-woocommerce/tags/8.2.0/",
  "https://wordpress.org/plugins/mollie-payments-for-woocommerce/"
 ],
 "attacksurface_url": "https://attacksurface.wpsec.com/plugin/mollie-payments-for-woocommerce",
 "source": "WPSec",
 "license": {
  "name": "CC BY 4.0",
  "url": "https://creativecommons.org/licenses/by/4.0/"
 },
 "usage": {
  "plugin": "Low",
  "affected_versions": "Low",
  "as_of": "2026-10-28"
 }
}