# Mollie Payments for WooCommerce <= 8.1.11 - Unauthenticated Improper Input Validation to Restricted Product Purchase via PayPal Express Button

- **ID:** WPSEC-2026-1833
- **Plugin:** Mollie Payments for WooCommerce (`mollie-payments-for-woocommerce`), https://wordpress.org/plugins/mollie-payments-for-woocommerce/
- **Affected versions:** all versions before 8.2.0
- **Fixed in:** 8.2.0 (Update to 8.2.0 or later.)
- **Severity:** Medium 5.3 (CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N)
- **Weakness:** CWE-20
- **Usage among sites WPSec scans:** plugin Low, affected versions Low (as of 2026-10-28)
- **Attack surface analysis:** https://attacksurface.wpsec.com/plugin/mollie-payments-for-woocommerce
- **Fix released:** 2026-10-27
- **Published:** 2026-10-28
- **URL:** https://wpsec.com/vuln/WPSEC-2026-1833/

## Description

The Mollie Payments for WooCommerce plugin for WordPress is vulnerable to Improper Input Validation via the PayPal express button AJAX handlers in all versions up to, and including, 8.1.11, due to the product-page handler building a WooCommerce order from any product ID and quantity posted by the client, without checking that the product is published, purchasable, in stock, has enough stock, or is a product the button is offered for. This makes it possible for unauthenticated attackers to create and pay orders for private or draft products, out-of-stock items, or products the PayPal button is not shown for, bypassing the store's purchase restrictions. Exploitation requires the PayPal express button to be enabled.

## References

- https://wpsec.com/vuln/WPSEC-2026-1833/
- https://plugins.svn.wordpress.org/mollie-payments-for-woocommerce/tags/8.2.0/
- https://wordpress.org/plugins/mollie-payments-for-woocommerce/

Source: WPSec, https://wpsec.com/vuln/WPSEC-2026-1833/

License: CC BY 4.0 (https://creativecommons.org/licenses/by/4.0/). Free to use, share and adapt, also commercially, if you credit WPSec and link to this advisory.
