# YITH WooCommerce Gift Cards <= 4.38.0 - Unauthenticated Race Condition to Gift Card Balance Overspending

- **ID:** WPSEC-2026-1838
- **Plugin:** YITH WooCommerce Gift Cards (`yith-woocommerce-gift-cards`), https://wordpress.org/plugins/yith-woocommerce-gift-cards/
- **Affected versions:** all versions before 4.38.1
- **Fixed in:** 4.38.1 (Update to 4.38.1 or later.)
- **Severity:** Low 3.7 (CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N)
- **Weakness:** CWE-362
- **Usage among sites WPSec scans:** plugin Low, affected versions None seen (as of 2026-10-28)
- **Attack surface analysis:** https://attacksurface.wpsec.com/plugin/yith-woocommerce-gift-cards
- **Fix released:** 2026-10-27
- **Published:** 2026-10-28
- **URL:** https://wpsec.com/vuln/WPSEC-2026-1838/

## Description

The YITH WooCommerce Gift Cards plugin for WordPress is vulnerable to a Race Condition via gift card balance deduction during checkout in all versions up to, and including, 4.38.0, due to the balance being updated with a non-atomic read-modify-write and no check that the remaining balance covers the amount being deducted. This makes it possible for unauthenticated attackers, such as guest customers holding a gift card, to submit several checkouts with the same gift card at the same time and spend more than the card's actual balance.

## References

- https://wpsec.com/vuln/WPSEC-2026-1838/
- https://plugins.svn.wordpress.org/yith-woocommerce-gift-cards/tags/4.38.1/
- https://wordpress.org/plugins/yith-woocommerce-gift-cards/

Source: WPSec, https://wpsec.com/vuln/WPSEC-2026-1838/

License: CC BY 4.0 (https://creativecommons.org/licenses/by/4.0/). Free to use, share and adapt, also commercially, if you credit WPSec and link to this advisory.
