{
 "id": "WPSEC-2026-1840",
 "url": "https://wpsec.com/vuln/WPSEC-2026-1840/",
 "json_url": "https://wpsec.com/vuln/WPSEC-2026-1840/advisory.json",
 "markdown_url": "https://wpsec.com/vuln/WPSEC-2026-1840/index.md",
 "title": "Strong Testimonials <= 3.3.15 - Authenticated (Contributor+) Stored Cross-Site Scripting via testimonial_view Shortcode Attributes",
 "description": "The Strong Testimonials plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the testimonial_view shortcode's attributes in all versions up to, and including, 3.3.15, due to insufficient input sanitization and output escaping. User-supplied shortcode attributes could override the internal 'view_not_found' flag, so a view that failed validation was still rendered with an attacker-controlled 'view' value. In slideshow mode that value was concatenated unescaped into a JavaScript variable name printed in an inline script. The 'thumbnail_width' and 'thumbnail_height' attributes were also placed unescaped into image tag attributes for imported review thumbnails. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.",
 "plugin": {
  "slug": "strong-testimonials",
  "name": "Strong Testimonials",
  "full_name": "Strong Testimonials",
  "wordpress_org": "https://wordpress.org/plugins/strong-testimonials/",
  "advisories_url": "https://wpsec.com/vuln/plugin/strong-testimonials/",
  "attacksurface": "https://attacksurface.wpsec.com/plugin/strong-testimonials"
 },
 "type": "XSS",
 "cwe": [
  "CWE-79"
 ],
 "cve": [],
 "cvss": {
  "version": "3.1",
  "score": 6.4,
  "vector": "CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N",
  "severity": "Medium"
 },
 "affected": {
  "ranges": [
   {
    "from": null,
    "from_inclusive": true,
    "to": "3.3.16",
    "to_inclusive": false
   }
  ],
  "text": [
   "all versions before 3.3.16"
  ]
 },
 "introduced_in": null,
 "fixed_in": "3.3.16",
 "remediation": "Update to 3.3.16 or later.",
 "fix_released": "2026-10-27T12:54:33+00:00",
 "published": "2026-10-28T13:48:24+00:00",
 "updated": "2026-10-28T09:11:31.495862+00:00",
 "also_published_as": null,
 "references": [
  "https://wpsec.com/vuln/WPSEC-2026-1840/",
  "https://plugins.svn.wordpress.org/strong-testimonials/tags/3.3.16/",
  "https://wordpress.org/plugins/strong-testimonials/"
 ],
 "attacksurface_url": "https://attacksurface.wpsec.com/plugin/strong-testimonials",
 "source": "WPSec",
 "license": {
  "name": "CC BY 4.0",
  "url": "https://creativecommons.org/licenses/by/4.0/"
 },
 "usage": {
  "plugin": "Medium",
  "affected_versions": "Medium",
  "as_of": "2026-10-28"
 }
}