# Post Grid Gutenberg Blocks <= 5.1.1 - Authenticated (Editor+) Stored Cross-Site Scripting via Site Dark Logo

- **ID:** WPSEC-2026-1859
- **Plugin:** Post Grid Gutenberg Blocks for News, Magazines, Blog Websites – PostX (`ultimate-post`), https://wordpress.org/plugins/ultimate-post/
- **Affected versions:** from 3.1.9 before 5.1.2
- **Fixed in:** 5.1.2 (Update to 5.1.2 or later.)
- **Severity:** Medium 5.5 (CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:L/I:L/A:N)
- **Weakness:** CWE-79
- **Usage among sites WPSec scans:** plugin Medium, affected versions Medium (as of 2026-10-28)
- **Attack surface analysis:** https://attacksurface.wpsec.com/plugin/ultimate-post
- **Fix released:** 2026-10-27
- **Published:** 2026-10-28
- **URL:** https://wpsec.com/vuln/WPSEC-2026-1859/

## Description

The Post Grid Gutenberg Blocks plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the site dark logo setting in all versions up to, and including, 5.1.1, due to the /ultp/v2/init_site_dark_logo/ REST endpoint only requiring the edit_others_posts capability and storing the supplied logo URL without sanitization, and to that value being printed without escaping inside an inline style element on every page using the dark mode. This makes it possible for authenticated attackers, with Editor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

## References

- https://wpsec.com/vuln/WPSEC-2026-1859/
- https://plugins.svn.wordpress.org/ultimate-post/tags/5.1.2/
- https://wordpress.org/plugins/ultimate-post/

Source: WPSec, https://wpsec.com/vuln/WPSEC-2026-1859/

License: CC BY 4.0 (https://creativecommons.org/licenses/by/4.0/). Free to use, share and adapt, also commercially, if you credit WPSec and link to this advisory.
