{
 "id": "WPSEC-2026-1864",
 "url": "https://wpsec.com/vuln/WPSEC-2026-1864/",
 "json_url": "https://wpsec.com/vuln/WPSEC-2026-1864/advisory.json",
 "markdown_url": "https://wpsec.com/vuln/WPSEC-2026-1864/index.md",
 "title": "Leaky Paywall <= 5.3.0 - Unauthenticated Price Manipulation via 'plan_id' Parameter",
 "description": "The Leaky Paywall plugin for WordPress is vulnerable to price manipulation via the 'plan_id' parameter of the Stripe registration form in all versions up to, and including, 5.3.0, due to the Stripe price for a recurring subscription being taken from the hidden 'plan_id' field without checking that it matches the subscription level selected with 'level_id'. Registration completion then accepts any paid subscription on the customer. This makes it possible for unauthenticated attackers to get a more expensive level while being billed a cheaper Stripe price.",
 "plugin": {
  "slug": "leaky-paywall",
  "name": "Leaky Paywall",
  "full_name": "Leaky Paywall",
  "wordpress_org": "https://wordpress.org/plugins/leaky-paywall/",
  "advisories_url": "https://wpsec.com/vuln/plugin/leaky-paywall/",
  "attacksurface": "https://attacksurface.wpsec.com/plugin/leaky-paywall"
 },
 "type": "BYPASS",
 "cwe": [
  "CWE-472"
 ],
 "cve": [],
 "cvss": {
  "version": "3.1",
  "score": 5.3,
  "vector": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N",
  "severity": "Medium"
 },
 "affected": {
  "ranges": [
   {
    "from": null,
    "from_inclusive": true,
    "to": "5.3.1",
    "to_inclusive": false
   }
  ],
  "text": [
   "all versions before 5.3.1"
  ]
 },
 "introduced_in": null,
 "fixed_in": "5.3.1",
 "remediation": "Update to 5.3.1 or later.",
 "fix_released": "2026-10-27T18:38:20+00:00",
 "published": "2026-10-28T18:46:30+00:00",
 "updated": "2026-10-28T09:33:45.772629+00:00",
 "also_published_as": null,
 "references": [
  "https://wpsec.com/vuln/WPSEC-2026-1864/",
  "https://plugins.svn.wordpress.org/leaky-paywall/tags/5.3.1/",
  "https://wordpress.org/plugins/leaky-paywall/"
 ],
 "attacksurface_url": "https://attacksurface.wpsec.com/plugin/leaky-paywall",
 "source": "WPSec",
 "license": {
  "name": "CC BY 4.0",
  "url": "https://creativecommons.org/licenses/by/4.0/"
 },
 "usage": {
  "plugin": "Low",
  "affected_versions": "Low",
  "as_of": "2026-10-28"
 }
}