# Leaky Paywall <= 5.3.0 - Unauthenticated Price Manipulation via 'plan_id' Parameter

- **ID:** WPSEC-2026-1864
- **Plugin:** Leaky Paywall (`leaky-paywall`), https://wordpress.org/plugins/leaky-paywall/
- **Affected versions:** all versions before 5.3.1
- **Fixed in:** 5.3.1 (Update to 5.3.1 or later.)
- **Severity:** Medium 5.3 (CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N)
- **Weakness:** CWE-472
- **Usage among sites WPSec scans:** plugin Low, affected versions Low (as of 2026-10-28)
- **Attack surface analysis:** https://attacksurface.wpsec.com/plugin/leaky-paywall
- **Fix released:** 2026-10-27
- **Published:** 2026-10-28
- **URL:** https://wpsec.com/vuln/WPSEC-2026-1864/

## Description

The Leaky Paywall plugin for WordPress is vulnerable to price manipulation via the 'plan_id' parameter of the Stripe registration form in all versions up to, and including, 5.3.0, due to the Stripe price for a recurring subscription being taken from the hidden 'plan_id' field without checking that it matches the subscription level selected with 'level_id'. Registration completion then accepts any paid subscription on the customer. This makes it possible for unauthenticated attackers to get a more expensive level while being billed a cheaper Stripe price.

## References

- https://wpsec.com/vuln/WPSEC-2026-1864/
- https://plugins.svn.wordpress.org/leaky-paywall/tags/5.3.1/
- https://wordpress.org/plugins/leaky-paywall/

Source: WPSec, https://wpsec.com/vuln/WPSEC-2026-1864/

License: CC BY 4.0 (https://creativecommons.org/licenses/by/4.0/). Free to use, share and adapt, also commercially, if you credit WPSec and link to this advisory.
