{
 "id": "WPSEC-2026-1871",
 "url": "https://wpsec.com/vuln/WPSEC-2026-1871/",
 "json_url": "https://wpsec.com/vuln/WPSEC-2026-1871/advisory.json",
 "markdown_url": "https://wpsec.com/vuln/WPSEC-2026-1871/index.md",
 "title": "GiveWP <= 4.19.0.2 - Cross-Site Request Forgery to Multiple Administrative Actions",
 "description": "The GiveWP plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions 2.9.0 up to, and including, 4.19.0.2, due to missing nonce validation on several administrative request handlers: the PayPal Commerce onboarding AJAX actions (give_paypal_commerce_get_partner_url and give_paypal_commerce_user_on_boarded), the Stripe statement descriptor update and default Stripe account AJAX actions, the manual migration request (give-run-migration / give-clear-update), and the usage tracking opt-in action. These handlers checked only the manage_give_settings capability. This makes it possible for unauthenticated attackers to make the plugin change its PayPal Commerce account country and partner onboarding details, change the statement descriptor of a connected Stripe account or the default Stripe account, re-run or reset database migrations, or turn on usage tracking, via a forged request, provided they can trick a site administrator into performing an action such as clicking a link.",
 "plugin": {
  "slug": "give",
  "name": "GiveWP",
  "full_name": "GiveWP – Donation Plugin and Fundraising Platform",
  "wordpress_org": "https://wordpress.org/plugins/give/",
  "advisories_url": "https://wpsec.com/vuln/plugin/give/",
  "attacksurface": "https://attacksurface.wpsec.com/plugin/give"
 },
 "type": "CSRF",
 "cwe": [
  "CWE-352"
 ],
 "cve": [],
 "cvss": {
  "version": "3.1",
  "score": 4.3,
  "vector": "CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N",
  "severity": "Medium"
 },
 "affected": {
  "ranges": [
   {
    "from": "2.9.0",
    "from_inclusive": true,
    "to": "4.19.1",
    "to_inclusive": false
   }
  ],
  "text": [
   "from 2.9.0 before 4.19.1"
  ]
 },
 "introduced_in": "2.9.0",
 "fixed_in": "4.19.1",
 "remediation": "Update to 4.19.1 or later.",
 "fix_released": "2026-10-27T20:23:53+00:00",
 "published": "2026-10-28T20:44:49+00:00",
 "updated": "2026-10-28T09:11:18.388308+00:00",
 "also_published_as": null,
 "references": [
  "https://wpsec.com/vuln/WPSEC-2026-1871/",
  "https://plugins.svn.wordpress.org/give/tags/4.19.1/",
  "https://wordpress.org/plugins/give/"
 ],
 "attacksurface_url": "https://attacksurface.wpsec.com/plugin/give",
 "source": "WPSec",
 "license": {
  "name": "CC BY 4.0",
  "url": "https://creativecommons.org/licenses/by/4.0/"
 },
 "usage": {
  "plugin": "Medium",
  "affected_versions": "Medium",
  "as_of": "2026-10-28"
 }
}