# bbPress <= 2.6.20 - Unauthenticated Sensitive Information Exposure via BuddyPress Group Forums

- **ID:** WPSEC-2026-1880
- **Plugin:** bbPress (`bbpress`), https://wordpress.org/plugins/bbpress/
- **Affected versions:** all versions before 2.6.21
- **Fixed in:** 2.6.21 (Update to 2.6.21 or later.)
- **Severity:** Medium 5.3 (CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N)
- **Weakness:** CWE-200
- **Usage among sites WPSec scans:** plugin Medium, affected versions Medium (as of 2026-10-28)
- **Attack surface analysis:** https://attacksurface.wpsec.com/plugin/bbpress
- **Fix released:** 2026-10-27
- **Published:** 2026-10-28
- **URL:** https://wpsec.com/vuln/WPSEC-2026-1880/

## Description

The bbPress plugin for WordPress is vulnerable to Sensitive Information Exposure via BuddyPress group forums in all versions up to, and including, 2.6.20, due to group forum read checks ignoring BuddyPress community visibility. Public group forums were treated as readable by everyone even when the BuddyPress community was set to Members Only. This makes it possible for unauthenticated attackers to read group forums, topics and replies that the site restricts to logged-in community members.

## References

- https://wpsec.com/vuln/WPSEC-2026-1880/
- https://plugins.svn.wordpress.org/bbpress/tags/2.6.21/
- https://wordpress.org/plugins/bbpress/

Source: WPSec, https://wpsec.com/vuln/WPSEC-2026-1880/

License: CC BY 4.0 (https://creativecommons.org/licenses/by/4.0/). Free to use, share and adapt, also commercially, if you credit WPSec and link to this advisory.
