{
 "id": "WPSEC-2026-1889",
 "url": "https://wpsec.com/vuln/WPSEC-2026-1889/",
 "json_url": "https://wpsec.com/vuln/WPSEC-2026-1889/advisory.json",
 "markdown_url": "https://wpsec.com/vuln/WPSEC-2026-1889/index.md",
 "title": "jav's – WooCommerce and Trello integration WooTrello <= 3.3.1 - Cross-Site Request Forgery to Log and Integration Deletion",
 "description": "The jav's – WooCommerce and Trello integration WooTrello plugin for WordPress is vulnerable to Cross-Site Request Forgery via the logStatus, deleteLog, removeInt and wootrello_toggle_products_in_card actions of the settings page in all versions up to, and including, 3.3.1, due to missing nonce validation on these state-changing GET actions in the Wootrello_settings_view() function. This makes it possible for unauthenticated attackers to delete all plugin logs or all configured integrations, or toggle logging and the product-list option, via a forged request, granted they can trick a site administrator into performing an action such as clicking a link.",
 "plugin": {
  "slug": "wootrello",
  "name": "jav's – WooCommerce and Trello integration WooTrello",
  "full_name": "jav’s – WooCommerce and Trello integration WooTrello",
  "wordpress_org": "https://wordpress.org/plugins/wootrello/",
  "advisories_url": "https://wpsec.com/vuln/plugin/wootrello/",
  "attacksurface": "https://attacksurface.wpsec.com/plugin/wootrello"
 },
 "type": "CSRF",
 "cwe": [
  "CWE-352"
 ],
 "cve": [],
 "cvss": {
  "version": "3.1",
  "score": 4.3,
  "vector": "CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N",
  "severity": "Medium"
 },
 "affected": {
  "ranges": [
   {
    "from": null,
    "from_inclusive": true,
    "to": "3.4.0",
    "to_inclusive": false
   }
  ],
  "text": [
   "all versions before 3.4.0"
  ]
 },
 "introduced_in": null,
 "fixed_in": "3.4.0",
 "remediation": "Update to 3.4.0 or later.",
 "fix_released": "2026-10-28T04:06:50+00:00",
 "published": "2026-10-29T04:44:41+00:00",
 "updated": "2026-10-28T09:12:16.369397+00:00",
 "also_published_as": null,
 "references": [
  "https://wpsec.com/vuln/WPSEC-2026-1889/",
  "https://plugins.svn.wordpress.org/wootrello/tags/3.4.0/",
  "https://wordpress.org/plugins/wootrello/"
 ],
 "attacksurface_url": "https://attacksurface.wpsec.com/plugin/wootrello",
 "source": "WPSec",
 "license": {
  "name": "CC BY 4.0",
  "url": "https://creativecommons.org/licenses/by/4.0/"
 },
 "usage": {
  "plugin": "Low",
  "affected_versions": "None seen",
  "as_of": "2026-10-29"
 }
}