# jav's – WooCommerce and Trello integration WooTrello <= 3.3.1 - Cross-Site Request Forgery to Log and Integration Deletion

- **ID:** WPSEC-2026-1889
- **Plugin:** jav’s – WooCommerce and Trello integration WooTrello (`wootrello`), https://wordpress.org/plugins/wootrello/
- **Affected versions:** all versions before 3.4.0
- **Fixed in:** 3.4.0 (Update to 3.4.0 or later.)
- **Severity:** Medium 4.3 (CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N)
- **Weakness:** CWE-352
- **Usage among sites WPSec scans:** plugin Low, affected versions None seen (as of 2026-10-29)
- **Attack surface analysis:** https://attacksurface.wpsec.com/plugin/wootrello
- **Fix released:** 2026-10-28
- **Published:** 2026-10-29
- **URL:** https://wpsec.com/vuln/WPSEC-2026-1889/

## Description

The jav's – WooCommerce and Trello integration WooTrello plugin for WordPress is vulnerable to Cross-Site Request Forgery via the logStatus, deleteLog, removeInt and wootrello_toggle_products_in_card actions of the settings page in all versions up to, and including, 3.3.1, due to missing nonce validation on these state-changing GET actions in the Wootrello_settings_view() function. This makes it possible for unauthenticated attackers to delete all plugin logs or all configured integrations, or toggle logging and the product-list option, via a forged request, granted they can trick a site administrator into performing an action such as clicking a link.

## References

- https://wpsec.com/vuln/WPSEC-2026-1889/
- https://plugins.svn.wordpress.org/wootrello/tags/3.4.0/
- https://wordpress.org/plugins/wootrello/

Source: WPSec, https://wpsec.com/vuln/WPSEC-2026-1889/

License: CC BY 4.0 (https://creativecommons.org/licenses/by/4.0/). Free to use, share and adapt, also commercially, if you credit WPSec and link to this advisory.
