# Gift Cards (Gift Vouchers and Packages) (WooCommerce Supported) <= 4.8.6 - Cross-Site Request Forgery to Voucher Template Deletion

- **ID:** WPSEC-2026-1894
- **Plugin:** Gift Cards (Gift Vouchers and Packages) (WooCommerce Supported) (`gift-voucher`), https://wordpress.org/plugins/gift-voucher/
- **Affected versions:** all versions before 4.9.0
- **Fixed in:** 4.9.0 (Update to 4.9.0 or later.)
- **Severity:** Medium 4.3 (CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N)
- **Weakness:** CWE-352
- **Usage among sites WPSec scans:** plugin Low, affected versions None seen (as of 2026-10-29)
- **Attack surface analysis:** https://attacksurface.wpsec.com/plugin/gift-voucher
- **Fix released:** 2026-10-28
- **Published:** 2026-10-29
- **URL:** https://wpsec.com/vuln/WPSEC-2026-1894/

## Description

The Gift Cards (Gift Vouchers and Packages) (WooCommerce Supported) plugin for WordPress is vulnerable to Cross-Site Request Forgery via the 'bulk-delete' action of the legacy Voucher Templates screen in all versions up to, and including, 4.8.6, due to missing nonce validation in WPGV_Voucher_Template::process_bulk_action(). This makes it possible for unauthenticated attackers to delete voucher templates, including templates still used by existing orders, via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.

## References

- https://wpsec.com/vuln/WPSEC-2026-1894/
- https://plugins.svn.wordpress.org/gift-voucher/tags/4.9.0/
- https://wordpress.org/plugins/gift-voucher/

Source: WPSec, https://wpsec.com/vuln/WPSEC-2026-1894/

License: CC BY 4.0 (https://creativecommons.org/licenses/by/4.0/). Free to use, share and adapt, also commercially, if you credit WPSec and link to this advisory.
