{
 "id": "WPSEC-2026-1900",
 "url": "https://wpsec.com/vuln/WPSEC-2026-1900/",
 "json_url": "https://wpsec.com/vuln/WPSEC-2026-1900/advisory.json",
 "markdown_url": "https://wpsec.com/vuln/WPSEC-2026-1900/index.md",
 "title": "WPFunnels – Funnel Builder for WooCommerce with Checkout & One Click Upsell <= 3.13.5 - Authenticated (Contributor+) Stored Cross-Site Scripting via Gutenberg CSS",
 "description": "The WPFunnels plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the Gutenberg CSS REST routes in all versions up to, and including, 3.13.5 due to the routes only checking the edit_posts capability rather than permission to edit the targeted post, and insufficient sanitization that decoded HTML entities after stripping tags, allowing an encoded closing style tag to survive and be output raw inside a style block. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts into any post that will execute whenever a user accesses the affected page.",
 "plugin": {
  "slug": "wpfunnels",
  "name": "WPFunnels – Funnel Builder for WooCommerce with Checkout & One Click Upsell",
  "full_name": "WPFunnels – Funnel Builder for WooCommerce with Checkout & One Click Upsell",
  "wordpress_org": "https://wordpress.org/plugins/wpfunnels/",
  "advisories_url": "https://wpsec.com/vuln/plugin/wpfunnels/",
  "attacksurface": "https://attacksurface.wpsec.com/plugin/wpfunnels"
 },
 "type": "XSS",
 "cwe": [
  "CWE-79"
 ],
 "cve": [],
 "cvss": {
  "version": "3.1",
  "score": 6.4,
  "vector": "CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N",
  "severity": "Medium"
 },
 "affected": {
  "ranges": [
   {
    "from": null,
    "from_inclusive": true,
    "to": "3.13.6",
    "to_inclusive": false
   }
  ],
  "text": [
   "all versions before 3.13.6"
  ]
 },
 "introduced_in": null,
 "fixed_in": "3.13.6",
 "remediation": "Update to 3.13.6 or later.",
 "fix_released": "2026-10-28T06:05:57+00:00",
 "published": "2026-10-29T06:44:57+00:00",
 "updated": "2026-10-28T09:20:08.739060+00:00",
 "also_published_as": null,
 "references": [
  "https://wpsec.com/vuln/WPSEC-2026-1900/",
  "https://plugins.svn.wordpress.org/wpfunnels/tags/3.13.6/",
  "https://wordpress.org/plugins/wpfunnels/"
 ],
 "attacksurface_url": "https://attacksurface.wpsec.com/plugin/wpfunnels",
 "source": "WPSec",
 "license": {
  "name": "CC BY 4.0",
  "url": "https://creativecommons.org/licenses/by/4.0/"
 },
 "usage": {
  "plugin": "Low",
  "affected_versions": "Low",
  "as_of": "2026-10-29"
 }
}