# WPFunnels – Funnel Builder for WooCommerce with Checkout & One Click Upsell <= 3.13.5 - Missing Authorization to Unauthenticated Telemetry Opt-In/Opt-Out Change

- **ID:** WPSEC-2026-1902
- **Plugin:** WPFunnels – Funnel Builder for WooCommerce with Checkout & One Click Upsell (`wpfunnels`), https://wordpress.org/plugins/wpfunnels/
- **Affected versions:** all versions before 3.13.6
- **Fixed in:** 3.13.6 (Update to 3.13.6 or later.)
- **Severity:** Medium 5.3 (CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N)
- **Weakness:** CWE-862
- **Usage among sites WPSec scans:** plugin Low, affected versions Low (as of 2026-10-29)
- **Attack surface analysis:** https://attacksurface.wpsec.com/plugin/wpfunnels
- **Fix released:** 2026-10-28
- **Published:** 2026-10-29
- **URL:** https://wpsec.com/vuln/WPSEC-2026-1902/

## Description

The WPFunnels plugin for WordPress is vulnerable to unauthorized modification of data in all versions up to, and including, 3.13.5 due to the bundled telemetry consent handler running on admin_init without any login, capability or nonce check. This makes it possible for unauthenticated attackers to change the site's telemetry opt-in or opt-out setting via requests to admin-ajax.php or admin-post.php.

## References

- https://wpsec.com/vuln/WPSEC-2026-1902/
- https://plugins.svn.wordpress.org/wpfunnels/tags/3.13.6/
- https://wordpress.org/plugins/wpfunnels/

Source: WPSec, https://wpsec.com/vuln/WPSEC-2026-1902/

License: CC BY 4.0 (https://creativecommons.org/licenses/by/4.0/). Free to use, share and adapt, also commercially, if you credit WPSec and link to this advisory.
