# EventPrime <= 4.3.6.0 - Unauthenticated Sensitive Information Exposure via Public 'pending' Post Status

- **ID:** WPSEC-2026-1913
- **Plugin:** EventPrime – Events Calendar, Bookings, Tickets & AI (`eventprime-event-calendar-management`), https://wordpress.org/plugins/eventprime-event-calendar-management/
- **Affected versions:** all versions before 4.3.6.1
- **Fixed in:** 4.3.6.1 (Update to 4.3.6.1 or later.)
- **Severity:** Medium 5.3 (CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N)
- **Weakness:** CWE-200
- **Usage among sites WPSec scans:** plugin Medium, affected versions Medium (as of 2026-10-29)
- **Attack surface analysis:** https://attacksurface.wpsec.com/plugin/eventprime-event-calendar-management
- **Fix released:** 2026-10-28
- **Published:** 2026-10-29
- **URL:** https://wpsec.com/vuln/WPSEC-2026-1913/

## Description

The EventPrime plugin for WordPress is vulnerable to Sensitive Information Exposure via its booking post status registration in all versions up to, and including, 4.3.6.0, due to the plugin re-registering the global 'pending' post status as public, which overrides WordPress's built-in Pending Review status. This makes it possible for unauthenticated attackers to view posts, pages and other content awaiting review that should not yet be publicly accessible.

## References

- https://wpsec.com/vuln/WPSEC-2026-1913/
- https://plugins.svn.wordpress.org/eventprime-event-calendar-management/tags/4.3.6.1/
- https://wordpress.org/plugins/eventprime-event-calendar-management/

Source: WPSec, https://wpsec.com/vuln/WPSEC-2026-1913/

License: CC BY 4.0 (https://creativecommons.org/licenses/by/4.0/). Free to use, share and adapt, also commercially, if you credit WPSec and link to this advisory.
