{
 "id": "WPSEC-2026-1915",
 "url": "https://wpsec.com/vuln/WPSEC-2026-1915/",
 "json_url": "https://wpsec.com/vuln/WPSEC-2026-1915/advisory.json",
 "markdown_url": "https://wpsec.com/vuln/WPSEC-2026-1915/index.md",
 "title": "Post Grid Gutenberg Blocks <= 5.1.2 - Authenticated (Author+) Stored Cross-Site Scripting via Block CSS",
 "description": "The Post Grid Gutenberg Blocks plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the generated block CSS in all versions up to, and including, 5.1.2, due to the CSS sent to the /ultp/v1/save_block_css/ REST endpoint being stored unsanitized in the post's _ultp_css meta and CSS file, and later printed in an inline style element with wp_add_inline_style() without escaping, so a closing style tag in the CSS ends the style element. This makes it possible for authenticated attackers, with author-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.",
 "plugin": {
  "slug": "ultimate-post",
  "name": "Post Grid Gutenberg Blocks",
  "full_name": "Post Grid Gutenberg Blocks for News, Magazines, Blog Websites – PostX",
  "wordpress_org": "https://wordpress.org/plugins/ultimate-post/",
  "advisories_url": "https://wpsec.com/vuln/plugin/ultimate-post/",
  "attacksurface": "https://attacksurface.wpsec.com/plugin/ultimate-post"
 },
 "type": "XSS",
 "cwe": [
  "CWE-79"
 ],
 "cve": [],
 "cvss": {
  "version": "3.1",
  "score": 6.4,
  "vector": "CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N",
  "severity": "Medium"
 },
 "affected": {
  "ranges": [
   {
    "from": null,
    "from_inclusive": true,
    "to": "5.1.3",
    "to_inclusive": false
   }
  ],
  "text": [
   "all versions before 5.1.3"
  ]
 },
 "introduced_in": null,
 "fixed_in": "5.1.3",
 "remediation": "Update to 5.1.3 or later.",
 "fix_released": "2026-10-28T10:18:04+00:00",
 "published": "2026-10-29T18:50:39+00:00",
 "updated": "2026-10-29T17:42:12.426388+00:00",
 "also_published_as": null,
 "references": [
  "https://wpsec.com/vuln/WPSEC-2026-1915/",
  "https://plugins.svn.wordpress.org/ultimate-post/tags/5.1.3/",
  "https://wordpress.org/plugins/ultimate-post/"
 ],
 "attacksurface_url": "https://attacksurface.wpsec.com/plugin/ultimate-post",
 "source": "WPSec",
 "license": {
  "name": "CC BY 4.0",
  "url": "https://creativecommons.org/licenses/by/4.0/"
 },
 "usage": {
  "plugin": "Medium",
  "affected_versions": "Medium",
  "as_of": "2026-10-29"
 }
}