# Post Grid Gutenberg Blocks <= 5.1.2 - Authenticated (Author+) Stored Cross-Site Scripting via Block CSS

- **ID:** WPSEC-2026-1915
- **Plugin:** Post Grid Gutenberg Blocks for News, Magazines, Blog Websites – PostX (`ultimate-post`), https://wordpress.org/plugins/ultimate-post/
- **Affected versions:** all versions before 5.1.3
- **Fixed in:** 5.1.3 (Update to 5.1.3 or later.)
- **Severity:** Medium 6.4 (CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N)
- **Weakness:** CWE-79
- **Usage among sites WPSec scans:** plugin Medium, affected versions Medium (as of 2026-10-29)
- **Attack surface analysis:** https://attacksurface.wpsec.com/plugin/ultimate-post
- **Fix released:** 2026-10-28
- **Published:** 2026-10-29
- **URL:** https://wpsec.com/vuln/WPSEC-2026-1915/

## Description

The Post Grid Gutenberg Blocks plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the generated block CSS in all versions up to, and including, 5.1.2, due to the CSS sent to the /ultp/v1/save_block_css/ REST endpoint being stored unsanitized in the post's _ultp_css meta and CSS file, and later printed in an inline style element with wp_add_inline_style() without escaping, so a closing style tag in the CSS ends the style element. This makes it possible for authenticated attackers, with author-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

## References

- https://wpsec.com/vuln/WPSEC-2026-1915/
- https://plugins.svn.wordpress.org/ultimate-post/tags/5.1.3/
- https://wordpress.org/plugins/ultimate-post/

Source: WPSec, https://wpsec.com/vuln/WPSEC-2026-1915/

License: CC BY 4.0 (https://creativecommons.org/licenses/by/4.0/). Free to use, share and adapt, also commercially, if you credit WPSec and link to this advisory.
