{
 "id": "WPSEC-2026-1920",
 "url": "https://wpsec.com/vuln/WPSEC-2026-1920/",
 "json_url": "https://wpsec.com/vuln/WPSEC-2026-1920/advisory.json",
 "markdown_url": "https://wpsec.com/vuln/WPSEC-2026-1920/index.md",
 "title": "GTM Server Side <= 2.3.10 - Unauthenticated Server-Side Request Forgery via Same-Origin Proxy",
 "description": "The Stape Conversion Tracking plugin for WordPress is vulnerable to Server-Side Request Forgery via the same-origin proxy in versions 2.3.0 up to, and including, 2.3.10. This is due to the proxy sub-path, a public query variable that can be set from the query string, being appended to the configured Stape container endpoint without validation and fetched with wp_remote_request(). A sub-path holding userinfo (e.g. '@host') can therefore send the request to an arbitrary host, and the upstream response is returned to the requester. This makes it possible for unauthenticated attackers to make web requests to arbitrary locations from the web application, including internal services, and read the responses, when the same-origin proxy feature is enabled.",
 "plugin": {
  "slug": "gtm-server-side",
  "name": "GTM Server Side",
  "full_name": "Stape Conversion Tracking",
  "wordpress_org": "https://wordpress.org/plugins/gtm-server-side/",
  "advisories_url": "https://wpsec.com/vuln/plugin/gtm-server-side/",
  "attacksurface": "https://attacksurface.wpsec.com/plugin/gtm-server-side"
 },
 "type": "SSRF",
 "cwe": [
  "CWE-918"
 ],
 "cve": [],
 "cvss": {
  "version": "3.1",
  "score": 5.4,
  "vector": "CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:L/I:L/A:N",
  "severity": "Medium"
 },
 "affected": {
  "ranges": [
   {
    "from": "2.3.0",
    "from_inclusive": true,
    "to": "2.3.11",
    "to_inclusive": false
   }
  ],
  "text": [
   "from 2.3.0 before 2.3.11"
  ]
 },
 "introduced_in": "2.3.0",
 "fixed_in": "2.3.11",
 "remediation": "Update to 2.3.11 or later.",
 "fix_released": "2026-10-28T16:26:25+00:00",
 "published": "2026-10-29T18:50:39+00:00",
 "updated": "2026-10-29T17:42:33.614093+00:00",
 "also_published_as": null,
 "references": [
  "https://wpsec.com/vuln/WPSEC-2026-1920/",
  "https://plugins.svn.wordpress.org/gtm-server-side/tags/2.3.11/",
  "https://wordpress.org/plugins/gtm-server-side/"
 ],
 "attacksurface_url": "https://attacksurface.wpsec.com/plugin/gtm-server-side",
 "source": "WPSec",
 "license": {
  "name": "CC BY 4.0",
  "url": "https://creativecommons.org/licenses/by/4.0/"
 },
 "usage": {
  "plugin": "Medium",
  "affected_versions": "Medium",
  "as_of": "2026-10-29"
 }
}