# Responder <= 4.4.4 - Authenticated (Contributor+) Sensitive Information Exposure via Responder Debug Log Entries

- **ID:** WPSEC-2026-1928
- **Plugin:** Responder (`responder`), https://wordpress.org/plugins/responder/
- **Affected versions:** all versions before 4.4.5
- **Fixed in:** 4.4.5 (Update to 4.4.5 or later.)
- **Severity:** Low 3.1 (CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:N/A:N)
- **Weakness:** CWE-200
- **Usage among sites WPSec scans:** plugin Low, affected versions Low (as of 2026-10-29)
- **Attack surface analysis:** https://attacksurface.wpsec.com/plugin/responder
- **Fix released:** 2026-10-28
- **Published:** 2026-10-29
- **URL:** https://wpsec.com/vuln/WPSEC-2026-1928/

## Description

The Responder plugin for WordPress is vulnerable to Sensitive Information Exposure via the Responder Debug log (responder_debug custom post type) in all versions up to, and including, 4.4.4 due to the post type being registered with the default 'post' capability type and meta-capability mapping instead of administrator-only capabilities. This makes it possible for authenticated attackers, with Contributor-level access and above, to list debug entries whose titles reveal submitted lead identities, and for Editor-level users to open entries containing leads' names, email addresses, phone numbers and API responses. Exploitation requires the plugin's debug logging to be enabled.

## References

- https://wpsec.com/vuln/WPSEC-2026-1928/
- https://plugins.svn.wordpress.org/responder/tags/4.4.5/
- https://wordpress.org/plugins/responder/

Source: WPSec, https://wpsec.com/vuln/WPSEC-2026-1928/

License: CC BY 4.0 (https://creativecommons.org/licenses/by/4.0/). Free to use, share and adapt, also commercially, if you credit WPSec and link to this advisory.
