# Email Templates <= 1.5.14 - Unauthenticated Sensitive Information Exposure via WooCommerce Email Preview

- **ID:** WPSEC-2026-1935
- **Plugin:** Email Templates Customizer and Designer for WordPress and WooCommerce (`email-templates`), https://wordpress.org/plugins/email-templates/
- **Affected versions:** from 1.4 before 1.5.15
- **Fixed in:** 1.5.15 (Update to 1.5.15 or later.)
- **Severity:** Medium 5.3 (CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N)
- **Weakness:** CWE-862
- **Usage among sites WPSec scans:** plugin Low, affected versions None seen (as of 2026-10-29)
- **Attack surface analysis:** https://attacksurface.wpsec.com/plugin/email-templates
- **Fix released:** 2026-10-28
- **Published:** 2026-10-29
- **URL:** https://wpsec.com/vuln/WPSEC-2026-1935/

## Description

The Email Templates Customizer and Designer for WordPress and WooCommerce plugin for WordPress is vulnerable to Sensitive Information Exposure via the WooCommerce email preview in all versions up to, and including, 1.5.14, due to a missing capability check on the front-end preview handler and on the loading of real orders by the user-supplied preview_order ID, combined with a missing capability check on the admin_init redirect that hands out the 'open-email-template' preview nonce. This makes it possible for unauthenticated attackers to obtain a valid logged-out nonce and render WooCommerce email previews for arbitrary order IDs, exposing other customers' order data such as names, billing and shipping addresses, email addresses and purchased items, on sites where WooCommerce is active.

## References

- https://wpsec.com/vuln/WPSEC-2026-1935/
- https://plugins.svn.wordpress.org/email-templates/tags/1.5.15/
- https://wordpress.org/plugins/email-templates/

Source: WPSec, https://wpsec.com/vuln/WPSEC-2026-1935/

License: CC BY 4.0 (https://creativecommons.org/licenses/by/4.0/). Free to use, share and adapt, also commercially, if you credit WPSec and link to this advisory.
