{
 "id": "WPSEC-2026-1939",
 "url": "https://wpsec.com/vuln/WPSEC-2026-1939/",
 "json_url": "https://wpsec.com/vuln/WPSEC-2026-1939/advisory.json",
 "markdown_url": "https://wpsec.com/vuln/WPSEC-2026-1939/index.md",
 "title": "Essential Addons for Elementor – Popular Elementor Templates & Widgets <= 6.8.7 - Unauthenticated Privilege Escalation via Login | Register Widget Registration Role",
 "description": "The Essential Addons for Elementor plugin for WordPress is vulnerable to Privilege Escalation via the Login | Register widget's user registration handler in all versions up to, and including, 6.8.7. This is due to the handler accepting a client-supplied page_id that may point to a post revision, reading the new-user role from that revision's stored widget settings, and approving it based on the revision's author rather than the users responsible for the current page. This makes it possible for unauthenticated attackers, on sites that allow user registration, to register an account with an elevated role such as Editor when a revision saved by an administrator holds that role, for example a role the administrator has since removed, or one an author-level user wrote into the widget data before an administrator re-saved the page in Elementor.",
 "plugin": {
  "slug": "essential-addons-for-elementor-lite",
  "name": "Essential Addons for Elementor – Popular Elementor Templates & Widgets",
  "full_name": "Essential Addons for Elementor – Popular Elementor Templates & Widgets",
  "wordpress_org": "https://wordpress.org/plugins/essential-addons-for-elementor-lite/",
  "advisories_url": "https://wpsec.com/vuln/plugin/essential-addons-for-elementor-lite/",
  "attacksurface": "https://attacksurface.wpsec.com/plugin/essential-addons-for-elementor-lite"
 },
 "type": "PRIV",
 "cwe": [
  "CWE-269"
 ],
 "cve": [],
 "cvss": {
  "version": "3.1",
  "score": 8.1,
  "vector": "CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H",
  "severity": "High"
 },
 "affected": {
  "ranges": [
   {
    "from": null,
    "from_inclusive": true,
    "to": "6.8.8",
    "to_inclusive": false
   }
  ],
  "text": [
   "all versions before 6.8.8"
  ]
 },
 "introduced_in": null,
 "fixed_in": "6.8.8",
 "remediation": "Update to 6.8.8 or later.",
 "fix_released": "2026-10-28T11:26:42+00:00",
 "published": "2026-10-29T18:50:39+00:00",
 "updated": "2026-10-29T17:46:20.783001+00:00",
 "also_published_as": null,
 "references": [
  "https://wpsec.com/vuln/WPSEC-2026-1939/",
  "https://plugins.svn.wordpress.org/essential-addons-for-elementor-lite/tags/6.8.8/",
  "https://wordpress.org/plugins/essential-addons-for-elementor-lite/"
 ],
 "attacksurface_url": "https://attacksurface.wpsec.com/plugin/essential-addons-for-elementor-lite",
 "source": "WPSec",
 "license": {
  "name": "CC BY 4.0",
  "url": "https://creativecommons.org/licenses/by/4.0/"
 },
 "usage": {
  "plugin": "High",
  "affected_versions": "High",
  "as_of": "2026-10-29"
 }
}