{
 "id": "WPSEC-2026-1940",
 "url": "https://wpsec.com/vuln/WPSEC-2026-1940/",
 "json_url": "https://wpsec.com/vuln/WPSEC-2026-1940/advisory.json",
 "markdown_url": "https://wpsec.com/vuln/WPSEC-2026-1940/index.md",
 "title": "Essential Addons for Elementor – Popular Elementor Templates & Widgets <= 6.8.7 - Authenticated (Contributor+) Stored Cross-Site Scripting via Custom JS Page Setting",
 "description": "The Essential Addons for Elementor plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the Custom JS extension's page setting in all versions up to, and including, 6.8.7. This is due to the administrator-only restriction on Custom JS being applied only to Elementor's document save, while the eael_custom_js value in the _elementor_page_settings post meta, which can be written through the REST API by anyone who can edit the post, is copied unescaped into the page's front-end script on a later Elementor save. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary scripts that run whenever a user accesses the page, once the page is published and saved again in Elementor, for example by an administrator.",
 "plugin": {
  "slug": "essential-addons-for-elementor-lite",
  "name": "Essential Addons for Elementor – Popular Elementor Templates & Widgets",
  "full_name": "Essential Addons for Elementor – Popular Elementor Templates & Widgets",
  "wordpress_org": "https://wordpress.org/plugins/essential-addons-for-elementor-lite/",
  "advisories_url": "https://wpsec.com/vuln/plugin/essential-addons-for-elementor-lite/",
  "attacksurface": "https://attacksurface.wpsec.com/plugin/essential-addons-for-elementor-lite"
 },
 "type": "XSS",
 "cwe": [
  "CWE-79"
 ],
 "cve": [],
 "cvss": {
  "version": "3.1",
  "score": 5.4,
  "vector": "CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N",
  "severity": "Medium"
 },
 "affected": {
  "ranges": [
   {
    "from": null,
    "from_inclusive": true,
    "to": "6.8.8",
    "to_inclusive": false
   }
  ],
  "text": [
   "all versions before 6.8.8"
  ]
 },
 "introduced_in": null,
 "fixed_in": "6.8.8",
 "remediation": "Update to 6.8.8 or later.",
 "fix_released": "2026-10-28T11:26:42+00:00",
 "published": "2026-10-29T18:50:39+00:00",
 "updated": "2026-10-29T17:46:20.783001+00:00",
 "also_published_as": null,
 "references": [
  "https://wpsec.com/vuln/WPSEC-2026-1940/",
  "https://plugins.svn.wordpress.org/essential-addons-for-elementor-lite/tags/6.8.8/",
  "https://wordpress.org/plugins/essential-addons-for-elementor-lite/"
 ],
 "attacksurface_url": "https://attacksurface.wpsec.com/plugin/essential-addons-for-elementor-lite",
 "source": "WPSec",
 "license": {
  "name": "CC BY 4.0",
  "url": "https://creativecommons.org/licenses/by/4.0/"
 },
 "usage": {
  "plugin": "High",
  "affected_versions": "High",
  "as_of": "2026-10-29"
 }
}