# Essential Addons for Elementor – Popular Elementor Templates & Widgets <= 6.8.7 - Authenticated (Contributor+) Stored Cross-Site Scripting via Custom JS Page Setting

- **ID:** WPSEC-2026-1940
- **Plugin:** Essential Addons for Elementor – Popular Elementor Templates & Widgets (`essential-addons-for-elementor-lite`), https://wordpress.org/plugins/essential-addons-for-elementor-lite/
- **Affected versions:** all versions before 6.8.8
- **Fixed in:** 6.8.8 (Update to 6.8.8 or later.)
- **Severity:** Medium 5.4 (CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N)
- **Weakness:** CWE-79
- **Usage among sites WPSec scans:** plugin High, affected versions High (as of 2026-10-29)
- **Attack surface analysis:** https://attacksurface.wpsec.com/plugin/essential-addons-for-elementor-lite
- **Fix released:** 2026-10-28
- **Published:** 2026-10-29
- **URL:** https://wpsec.com/vuln/WPSEC-2026-1940/

## Description

The Essential Addons for Elementor plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the Custom JS extension's page setting in all versions up to, and including, 6.8.7. This is due to the administrator-only restriction on Custom JS being applied only to Elementor's document save, while the eael_custom_js value in the _elementor_page_settings post meta, which can be written through the REST API by anyone who can edit the post, is copied unescaped into the page's front-end script on a later Elementor save. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary scripts that run whenever a user accesses the page, once the page is published and saved again in Elementor, for example by an administrator.

## References

- https://wpsec.com/vuln/WPSEC-2026-1940/
- https://plugins.svn.wordpress.org/essential-addons-for-elementor-lite/tags/6.8.8/
- https://wordpress.org/plugins/essential-addons-for-elementor-lite/

Source: WPSec, https://wpsec.com/vuln/WPSEC-2026-1940/

License: CC BY 4.0 (https://creativecommons.org/licenses/by/4.0/). Free to use, share and adapt, also commercially, if you credit WPSec and link to this advisory.
