{
 "id": "WPSEC-2026-1943",
 "url": "https://wpsec.com/vuln/WPSEC-2026-1943/",
 "json_url": "https://wpsec.com/vuln/WPSEC-2026-1943/advisory.json",
 "markdown_url": "https://wpsec.com/vuln/WPSEC-2026-1943/index.md",
 "title": "Ad Inserter – Ad Manager & AdSense Ads <= 2.8.19 - Reflected Cross-Site Scripting via Request URI in Debugging Tools and {url} Tag",
 "description": "The Ad Inserter plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the request URI in all versions up to, and including, 2.8.19 due to insufficient output escaping. URLs built from the current request with remove_query_arg()/add_query_arg(), which return decoded query parameter names, were printed without escaping in the links of the front-end Debugging tools block and widget, and were substituted unescaped for the {url} tag in block code. The Debugging tools block also rendered for any visitor. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into clicking a crafted link.",
 "plugin": {
  "slug": "ad-inserter",
  "name": "Ad Inserter – Ad Manager & AdSense Ads",
  "full_name": "Ad Inserter – Ad Manager & AdSense Ads",
  "wordpress_org": "https://wordpress.org/plugins/ad-inserter/",
  "advisories_url": "https://wpsec.com/vuln/plugin/ad-inserter/",
  "attacksurface": "https://attacksurface.wpsec.com/plugin/ad-inserter"
 },
 "type": "XSS",
 "cwe": [
  "CWE-79"
 ],
 "cve": [],
 "cvss": {
  "version": "3.1",
  "score": 4.7,
  "vector": "CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:L/I:L/A:N",
  "severity": "Medium"
 },
 "affected": {
  "ranges": [
   {
    "from": null,
    "from_inclusive": true,
    "to": "2.8.20",
    "to_inclusive": false
   }
  ],
  "text": [
   "all versions before 2.8.20"
  ]
 },
 "introduced_in": null,
 "fixed_in": "2.8.20",
 "remediation": "Update to 2.8.20 or later.",
 "fix_released": "2026-10-28T10:25:13+00:00",
 "published": "2026-10-29T18:50:39+00:00",
 "updated": "2026-10-29T17:46:46.730215+00:00",
 "also_published_as": null,
 "references": [
  "https://wpsec.com/vuln/WPSEC-2026-1943/",
  "https://plugins.svn.wordpress.org/ad-inserter/tags/2.8.20/",
  "https://wordpress.org/plugins/ad-inserter/"
 ],
 "attacksurface_url": "https://attacksurface.wpsec.com/plugin/ad-inserter",
 "source": "WPSec",
 "license": {
  "name": "CC BY 4.0",
  "url": "https://creativecommons.org/licenses/by/4.0/"
 },
 "usage": {
  "plugin": "Low",
  "affected_versions": "Low",
  "as_of": "2026-10-29"
 }
}